summaryrefslogtreecommitdiffstats
path: root/recipes-demo/agl-vss-helper
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>2024-08-17 12:37:34 +0000
commit62c27830707e134dfe18662fb304c5905ead49af (patch)
tree776975c7a0eaf09b5ccdc4a0c8d8879d2dbd1a21 /recipes-demo/agl-vss-helper
parentda95381c1a7f3ad1455cd0da8da48d34b187186b (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/agl-vss-helper')
-rw-r--r--recipes-demo/agl-vss-helper/agl-vss-helper.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-demo/agl-vss-helper/agl-vss-helper.bb b/recipes-demo/agl-vss-helper/agl-vss-helper.bb
index 88e14511a..be555dab8 100644
--- a/recipes-demo/agl-vss-helper/agl-vss-helper.bb
+++ b/recipes-demo/agl-vss-helper/agl-vss-helper.bb
@@ -8,6 +8,9 @@ SRC_URI = "file://agl-vss-helper.py \
file://agl-vss-helper.service \
"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
inherit systemd
SYSTEMD_SERVICE:${PN} = "${BPN}.service"
@@ -17,11 +20,11 @@ do_compile[noexec] = "1"
do_install() {
install -d ${D}${sbindir}
- install -m 0755 ${WORKDIR}/${BPN}.py ${D}${sbindir}
+ install -m 0755 ${UNPACKDIR}/${BPN}.py ${D}${sbindir}
install -d ${D}${sysconfdir}/xdg/AGL/${BPN}
- install -m 0644 ${WORKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
- install -m 0644 ${WORKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
- install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
+ install -m 0644 ${UNPACKDIR}/${BPN}.yaml ${D}${sysconfdir}/xdg/AGL/
+ install -m 0644 ${UNPACKDIR}/${BPN}.token ${D}${sysconfdir}/xdg/AGL/${BPN}/
+ install -D -m 0644 ${UNPACKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
}
RDEPENDS:${PN} = " \