summaryrefslogtreecommitdiffstats
path: root/recipes-demo/radio/radio_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-05-23 10:21:50 -0400
committerScott Murray <scott.murray@konsulko.com>2024-05-23 10:22:43 -0400
commit4ed1a0a0302cec13f12d3999466d62841c104402 (patch)
tree3800d3c40398a5441122e5b04bd6aeac6ee88945 /recipes-demo/radio/radio_git.bb
parentfe2024e444f214ed6fd04c37d09c51f1c6a9e8e6 (diff)
Update recipes for transition to UNPACKDIRnext
Update recipes to handle the transition to using UNPACKDIR as the destination for unpacked files. For recipes that had been using S = WORKDIR, the approach used in meta-openembedded has been followed, i.e. using UNPACKDIR in tasks for consistency. Bug-AGL: SPEC-5147 Change-Id: I42b2b474be163c66e11a449de6eec7d748e00fbb Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-demo/radio/radio_git.bb')
-rw-r--r--recipes-demo/radio/radio_git.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
index c9d8ed7a..ba8c70ba 100644
--- a/recipes-demo/radio/radio_git.bb
+++ b/recipes-demo/radio/radio_git.bb
@@ -27,10 +27,10 @@ AGL_APP_NAME = "Radio"
AGL_RADIO_PRESETS_LOCALE ?= "CES"
do_install:append() {
install -d ${D}${sysconfdir}/xdg/AGL
- install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
- install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
- install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
- install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
+ install -m 0644 ${UNPACKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
+ install -m 0644 ${UNPACKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
+ install -m 0644 ${UNPACKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
+ install -m 0644 ${UNPACKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
}
FILES:${PN} += "${sysconfdir}/xdg/AGL/*"