summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-03-24 14:48:14 +0800
committerduerpei <duep.fnst@fujitsu.com>2022-03-24 14:48:14 +0800
commitbbdac38957c239b73bcbf409be2efceef3e5d6f5 (patch)
treed0ec23c743e4fd5ca0f86d1d690d608a3f6d2d72 /recipes-demo
parent866d959acd29437ed96780fdea86bbc55e298fb2 (diff)
html5-hvac_git: Remove autobuild script builds
Bug-AGL: SPEC-4309 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Idef28f993af074f7e43b6475b4b53576572f7d9e
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 85fed294..16bf739c 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"
do_compile() {
- bldcmd=${S}/autobuild/agl/autobuild
cd ${S}
- $bldcmd build
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -35,4 +36,4 @@ do_install() {
FILES_${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
-" \ No newline at end of file
+"