summaryrefslogtreecommitdiffstats
path: root/recipes-demo
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo')
-rw-r--r--recipes-demo/html5-hvac/html5-hvac_git.bb7
1 files changed, 4 insertions, 3 deletions
diff --git a/recipes-demo/html5-hvac/html5-hvac_git.bb b/recipes-demo/html5-hvac/html5-hvac_git.bb
index 85fed294..16bf739c 100644
--- a/recipes-demo/html5-hvac/html5-hvac_git.bb
+++ b/recipes-demo/html5-hvac/html5-hvac_git.bb
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
DEPENDS = "nodejs-native"
do_compile() {
- bldcmd=${S}/autobuild/agl/autobuild
cd ${S}
- $bldcmd build
+ rm -rf package node_modules package-lock.json
+ npm install
+ npm run build
}
WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -35,4 +36,4 @@ do_install() {
FILES_${PN} = " \
${WAM_APPLICATIONS_DIR}/${PN} \
${APPLICATIONS_DIR} \
-" \ No newline at end of file
+"