summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-03-14 22:30:47 +0100
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-08-01 11:07:58 +0000
commit1455ac09ce2334853b9a9b8c5305016f15b1d379 (patch)
tree7338199ffdc6f4346676fba6a3ce4dc4a8783acf /recipes-graphics
parent60512754869a1e7ff162b6b3767b98f88845215a (diff)
web-runtime: Use runxdg for running QtWebEngine
Bug-AGL: SPEC-1346 Change-Id: I4783d06b008864a4703afe7364c5bec413590fc0 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
Diffstat (limited to 'recipes-graphics')
-rwxr-xr-xrecipes-graphics/web-runtime/web-runtime/web-runtime19
-rw-r--r--recipes-graphics/web-runtime/web-runtime_0.1.bb3
2 files changed, 20 insertions, 2 deletions
diff --git a/recipes-graphics/web-runtime/web-runtime/web-runtime b/recipes-graphics/web-runtime/web-runtime/web-runtime
index 80685eb8..ad791555 100755
--- a/recipes-graphics/web-runtime/web-runtime/web-runtime
+++ b/recipes-graphics/web-runtime/web-runtime/web-runtime
@@ -1,2 +1,17 @@
-#!/bin/sh
-exec /usr/bin/qt5/qmlscene "$1" /usr/bin/web-runtime.qml
+#!/bin/bash
+export -n QT_WAYLAND_SHELL_INTEGRATION
+port=$(echo -n "$1" | sed 's,.*local.*:\([^/]*\)/.*,\1,')
+token=$(echo -n "$1" | sed 's,.*token=,,')
+export AFM_APP_INSTALL_DIR=$(mktemp -d)
+cat << EOC > $AFM_APP_INSTALL_DIR/runxdg.toml
+[application]
+role = "WebBrowser"
+method = "POSIX"
+path = "/usr/bin/qt5/qmlscene"
+params = [
+ "$1",
+ "/usr/bin/web-runtime.qml"
+]
+EOC
+/usr/bin/runxdg "$port" "$token"
+rm -rf $AFM_APP_INSTALL_DIR
diff --git a/recipes-graphics/web-runtime/web-runtime_0.1.bb b/recipes-graphics/web-runtime/web-runtime_0.1.bb
index bdfcbecb..ea5acbbf 100644
--- a/recipes-graphics/web-runtime/web-runtime_0.1.bb
+++ b/recipes-graphics/web-runtime/web-runtime_0.1.bb
@@ -16,6 +16,9 @@ RDEPENDS_${PN} = "\
qtdeclarative-tools \
qtwayland-qmlplugins \
qtquickcontrols-qmlplugins \
+ qtwebengine \
+ runxdg \
+ bash \
"
PROVIDES += "virtual/webruntime"