summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-07-27 17:02:54 -0400
committerScott Murray <scott.murray@konsulko.com>2022-07-27 19:39:16 -0400
commit731adc93b2fed74bc4410dff510fb019d10f253f (patch)
tree77f17ab8b7b906a288d84f99f2cb4cde6fa537ff /recipes-graphics
parentf22d415e4b1290cbba736df7d4cafa043dc8f8f2 (diff)
Updates for application enumeration via systemd units
Update application recipes to use the new agl-app.bbclass to install the now required by applaunchd systemd template unit instances. The previously used .desktop files have been removed, and it is believed that the required configuration with respect to application display names has been captured in the new agl-app configuration variables. Bug-AGL: SPEC-4466 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I2925a68f911646c287bc7128bb0e5f43d55ce7bf
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb26
1 files changed, 8 insertions, 18 deletions
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
index 573e2df0..a34c4148 100644
--- a/recipes-graphics/wayland/weston-terminal-conf.bb
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -2,30 +2,20 @@ SUMMARY = "AGL user session"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-SRC_URI = " \
- file://org.freedesktop.weston.wayland-terminal.desktop \
- file://weston-terminal.desktop \
-"
+inherit allarch agl-app
-inherit allarch
+AGL_APP_ID = "org.freedesktop.weston.wayland-terminal"
+AGL_APP_EXEC = "weston-terminal"
+AGL_APP_NAME = "Weston Terminal"
do_install() {
- install -d ${D}${datadir}/applications
- install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
-
# Enable systemd sandboxing override as a demonstration
- mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
- ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
-
- # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
- install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
+ install -d ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
+ ln -sf ${systemd_system_unitdir}/sandboxing/no-network.conf ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
}
FILES:${PN} = " \
- ${datadir}/applications \
- ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
+ ${sysconfdir}/systemd/system/agl-app@${AGL_APP_ID}.service.d \
"
-RDEPENDS:${PN} = " \
- weston \
-"
+RDEPENDS:${PN} = "weston"