summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston-terminal-conf.bb26
1 files changed, 8 insertions, 18 deletions
diff --git a/recipes-graphics/wayland/weston-terminal-conf.bb b/recipes-graphics/wayland/weston-terminal-conf.bb
index 573e2df0..a34c4148 100644
--- a/recipes-graphics/wayland/weston-terminal-conf.bb
+++ b/recipes-graphics/wayland/weston-terminal-conf.bb
@@ -2,30 +2,20 @@ SUMMARY = "AGL user session"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
-SRC_URI = " \
- file://org.freedesktop.weston.wayland-terminal.desktop \
- file://weston-terminal.desktop \
-"
+inherit allarch agl-app
-inherit allarch
+AGL_APP_ID = "org.freedesktop.weston.wayland-terminal"
+AGL_APP_EXEC = "weston-terminal"
+AGL_APP_NAME = "Weston Terminal"
do_install() {
- install -d ${D}${datadir}/applications
- install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
-
# Enable systemd sandboxing override as a demonstration
- mkdir -p ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
- ln -sf ${sysconfdir}/systemd/sandboxing/no-network.conf ${D}${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d/
-
- # HACK - install .desktop file for systemd until applaunchd can do enumeration with homescreen names and icons
- install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications/
+ install -d ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
+ ln -sf ${systemd_system_unitdir}/sandboxing/no-network.conf ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
}
FILES:${PN} = " \
- ${datadir}/applications \
- ${sysconfdir}/systemd/system/agl-app@weston-terminal.service.d \
+ ${sysconfdir}/systemd/system/agl-app@${AGL_APP_ID}.service.d \
"
-RDEPENDS:${PN} = " \
- weston \
-"
+RDEPENDS:${PN} = "weston"