summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/aim-network/aim-network.bb
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-06-09 11:27:04 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-12 08:34:59 +0000
commita22fe6936f2256b4e8f23d6f7e2494b8e6ac7a65 (patch)
tree015b0559d8bf004417c3b1360641cb9d65b62938 /recipes-kernel/aim-network/aim-network.bb
parent13abc8463dbacc672769f66f27d926cc13524d97 (diff)
fix MOST driver dependency issues
This patch adds a new "most" receipe for building the MOST driver. The receipe replaces the old ones, as it builds all modules at once. Hence, the receipes aim*, hdm* and mostcore are removed. Additionally, the *.bb file for the demo platform is modified to reflect these changes. This patch is needed to avoid dependency issues among the modules of the driver stack. Although, the problem has been reported with SPEC 438 and a patch set to fix it has been introduced with Change #8447, it is still present on RaspberryPi. Change-Id: Id6104ee6d9bf1b7d9744761a6529461176fdd8b2 Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/aim-network/aim-network.bb')
-rw-r--r--recipes-kernel/aim-network/aim-network.bb25
1 files changed, 0 insertions, 25 deletions
diff --git a/recipes-kernel/aim-network/aim-network.bb b/recipes-kernel/aim-network/aim-network.bb
deleted file mode 100644
index 7ef192ce..00000000
--- a/recipes-kernel/aim-network/aim-network.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Build networking driver for MOST"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-DEPENDS = " mostcore"
-
-inherit module
-
-PV = "0.1"
-
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https"
-SRC_URI_append_porter = " file://0001-aim-network-backport-patch-for-3.10.31-ltsi.patch"
-
-S = "${WORKDIR}/git/driver/${PN}"
-SRCREV = "${AUTOREV}"
-
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
-
-do_install_append () {
- # modprobe automatically at boot
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${sysconfdir}/modules-load.d
- echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
- fi
-}