summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch
diff options
context:
space:
mode:
authorChristian Gromm <christian.gromm@microchip.com>2017-06-09 11:27:04 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-12 08:34:59 +0000
commita22fe6936f2256b4e8f23d6f7e2494b8e6ac7a65 (patch)
tree015b0559d8bf004417c3b1360641cb9d65b62938 /recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch
parent13abc8463dbacc672769f66f27d926cc13524d97 (diff)
fix MOST driver dependency issues
This patch adds a new "most" receipe for building the MOST driver. The receipe replaces the old ones, as it builds all modules at once. Hence, the receipes aim*, hdm* and mostcore are removed. Additionally, the *.bb file for the demo platform is modified to reflect these changes. This patch is needed to avoid dependency issues among the modules of the driver stack. Although, the problem has been reported with SPEC 438 and a patch set to fix it has been introduced with Change #8447, it is still present on RaspberryPi. Change-Id: Id6104ee6d9bf1b7d9744761a6529461176fdd8b2 Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
Diffstat (limited to 'recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch')
-rw-r--r--recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch b/recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch
new file mode 100644
index 00000000..31e9400d
--- /dev/null
+++ b/recipes-kernel/most/files/0001-aim-sound-3.10.31-ltsi-backport.patch
@@ -0,0 +1,29 @@
+From 686130266ff7968edc863d398fba82bd0f78bf29 Mon Sep 17 00:00:00 2001
+From: Christian Gromm <christian.gromm@microchip.com>
+Date: Wed, 28 Sep 2016 13:43:36 +0200
+Subject: [PATCH 1/4] backport module
+
+This patch replaces function snd_card_new() with snd_card_create() to match
+AGL/Renesas kernel API.
+
+Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
+---
+ aim-sound/sound.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/aim-sound/sound.c b/aim-sound/sound.c
+index 3dc625c..af0af2d 100644
+--- a/aim-sound/sound.c
++++ b/aim-sound/sound.c
+@@ -595,7 +595,7 @@ static int audio_probe_channel(struct most_interface *iface, int channel_id,
+ return ret;
+ }
+
+- ret = snd_card_new(NULL, -1, card_name, THIS_MODULE,
++ ret = snd_card_create(-1, card_name, THIS_MODULE,
+ sizeof(*channel), &card);
+ if (ret < 0)
+ return ret;
+--
+1.7.9.5
+