summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-demo-platform.bb
diff options
context:
space:
mode:
authorRonan <ronan.lemartret@iot.bzh>2017-01-20 16:18:55 +0100
committerRonan Le Martret <ronan.lemartret@iot.bzh>2017-02-21 16:31:27 +0100
commit69dabb655f1c98924a60d19cd442590ccb258ce5 (patch)
tree703e2c1d3ae81ce3728d5aa9cedc26b9248abb52 /recipes-platform/images/agl-demo-platform.bb
parent7bb3630d56eaf54bbb59bfac22ddca695f8d9dcd (diff)
add dependency to images
* [SPEC-424] * yocto image should use dependency to facilitate maintenance * yocto image should have its own LICENSE defined Change-Id: Ie7f2e48bab9cc194ce10e7d364e150d2678e64d6 Signed-off-by: Ronan <ronan.lemartret@iot.bzh>
Diffstat (limited to 'recipes-platform/images/agl-demo-platform.bb')
-rw-r--r--recipes-platform/images/agl-demo-platform.bb77
1 files changed, 4 insertions, 73 deletions
diff --git a/recipes-platform/images/agl-demo-platform.bb b/recipes-platform/images/agl-demo-platform.bb
index ff64f136..297cb706 100644
--- a/recipes-platform/images/agl-demo-platform.bb
+++ b/recipes-platform/images/agl-demo-platform.bb
@@ -1,84 +1,15 @@
-# Base image
-require recipes-ivi/images/agl-image-ivi.inc
-
DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
demos."
+require agl-demo-platform.inc
+
+LICENSE = "MIT"
+
IMAGE_FEATURES_append = " \
"
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL_append = " \
- packagegroup-agl-core \
- packagegroup-agl-ivi \
- packagegroup-ivi-common-core \
packagegroup-agl-demo-platform \
"
-# fonts
-IMAGE_TTF_FONTS = " \
- ttf-bitstream-vera \
- ttf-dejavu-sans \
- ttf-dejavu-sans-mono \
- ttf-dejavu-serif \
- "
-
-# add packages for CES2017 demo
-# Only for porter as these kernel module sources
-# are for the 3.10.x kernel only
-MOST_DRIVERS = " "
-MOST_DRIVERS_append = " \
- aim-cdev \
- aim-network \
- aim-sound \
- aim-v4l2 \
- hdm-dim2 \
- hdm-i2c \
- hdm-usb \
- mocca-usb \
- mostcore \
- "
-
-# HVAC dependencies depend on drivers above
-IMAGE_MOST_HVAC = " "
-IMAGE_MOST_HVAC_append = " \
- ${MOST_DRIVERS} \
- unicens \
- vod-server \
- "
-
-# can-lin is a binary and only for porter :(
-IMAGE_MOST_HVAC_append_porter = " \
- can-lin \
- "
-
-# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-IMAGE_MAPVIEWER = " "
-IMAGE_MAPVIEWER_append_porter = " \
- mapviewer \
- mapviewer-demo \
- "
-
-IMAGE_AGL_APPS = " \
- hvac \
- mediaplayer \
- mixer \
- navigation \
- settings \
- "
-
-IMAGE_INSTALL_append = " \
- ces2017-demo \
- linux-firmware-ath9k \
- linux-firmware-ralink \
- can-utils \
- iproute2 \
- python-curses \
- dhcp-client \
- navigation \
- poiapp \
- ${IMAGE_MAPVIEWER} \
- ${IMAGE_MOST_HVAC} \
- ${IMAGE_AGL_APPS} \
- ${IMAGE_TTF_FONTS} \
- "