summaryrefslogtreecommitdiffstats
path: root/recipes-platform/images/agl-ivi-demo-platform.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-12-08 11:03:34 +0900
committerScott Murray <scott.murray@konsulko.com>2022-12-10 07:48:55 +0000
commit18e7f90492c1bc15018ac7b20f166d54454626a9 (patch)
tree088982bcb20110197553eb855052d9e45ec94cd4 /recipes-platform/images/agl-ivi-demo-platform.bb
parent65ac0bfdce938aa98b232cbdf42cb84c41257488 (diff)
Update Flutter demo images
Changes: - Split demo image feature definitions into an include file to allow reusing them, and pull into both the Qt and Flutter demo platform images. - Remove packagegroup-agl-demo-platform dependencies from feature packagegroups so they will not break the Flutter images. - Tweak Flutter cluster demo image to have KUKSA.val related package omission be controlled by the "agl-demo-preload" feature. - Add the kuksa-vss-init package to the IVI services packagegroup so that the signal initialization expected by the Flutter cluster dashboard will always be done. This covers the usecase of using the Flutter cluster with KUKSA.val on the IVI board. - Add missing "agl-demo-preload" tweaks from the Qt demo platform image to the Flutter one. - Tweak things to leave out the Weston terminal app from images build with the "agl-demo-preload" feature. - Remove flutter-navigation and flutter-mediaplayer from the Flutter demo image for now, and add the messaging, phone, and radio Qt apps to fill out the list of apps for the demo. Bug-AGL: SPEC-4636, SPEC-4637, SPEC-4639 Change-Id: I9cde89278f0191886152f765d4fb1a893c0ea2c1 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform/images/agl-ivi-demo-platform.bb')
-rw-r--r--recipes-platform/images/agl-ivi-demo-platform.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-platform/images/agl-ivi-demo-platform.bb b/recipes-platform/images/agl-ivi-demo-platform.bb
index d3bda6ae..e82a474e 100644
--- a/recipes-platform/images/agl-ivi-demo-platform.bb
+++ b/recipes-platform/images/agl-ivi-demo-platform.bb
@@ -3,13 +3,11 @@ require agl-image-ivi.bb
DESCRIPTION = "AGL Demo Platform image currently contains a simple HMI and \
demos."
-FEATURE_PACKAGES_agl-demo-preload = "packagegroup-agl-demo-preload"
-FEATURE_PACKAGES_agl-demo-cluster-support = "packagegroup-agl-demo-cluster-support"
-
-IMAGE_FEATURES += "${@bb.utils.filter("AGL_FEATURES", "agl-demo-preload agl-demo-cluster-support", d)}"
+require agl-demo-features.inc
# add packages for demo platform (include demo apps) here
IMAGE_INSTALL:append = " \
packagegroup-agl-demo-platform \
+ ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "weston-terminal-conf", d)} \
"