summaryrefslogtreecommitdiffstats
path: root/recipes-platform
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2023-04-18 18:20:12 -0400
committerScott Murray <scott.murray@konsulko.com>2023-04-18 18:27:34 -0400
commit6e5d281b2015dfbdee5e153ffeb3e3b5358f7f1c (patch)
treebcf2321a93f29557e6294cc9bd60fb20315beb2d /recipes-platform
parent32774623cb239d420bc226f437e01c3eaacb1a28 (diff)
Fix building agl-kvm-demo-platform for h3ulcb-kf
Changes: - Add masking the meta-rcar-gen3-adas layer to the KVM guest multiconfig to avoid picking up the dangling bbappends in meta-agl-bsp when building the guests. - Remove the MACHINE_SUFFIX logic from the guest image copying in the agl-kvm-demo-platform recipe; it is a leftover from the original logic used in the IC EG container host images, and is unneeded here since the host and guests will be different MACHINEs (and the guest realistically cannot use the -kf machines). Bug-AGL: SPEC-4760 Change-Id: If3237ca4d9fc86fc9d289a95bda24a4afcc7a991 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'recipes-platform')
-rw-r--r--recipes-platform/images/agl-kvm-demo-platform.bb5
1 files changed, 1 insertions, 4 deletions
diff --git a/recipes-platform/images/agl-kvm-demo-platform.bb b/recipes-platform/images/agl-kvm-demo-platform.bb
index d04186b2..378ea832 100644
--- a/recipes-platform/images/agl-kvm-demo-platform.bb
+++ b/recipes-platform/images/agl-kvm-demo-platform.bb
@@ -36,9 +36,6 @@ GUEST_IMAGES ?= "agl-kvm-guest:${GUEST_VM1_IMAGE} agl-kvm-guest:${GUEST_VM2_IMAG
QEMU_GUEST_CONFIGS ?= ""
-# Handle modification of IMAGE_LINK_NAME done by ULCB builds with Kingfisher support
-MACHINE_SUFFIX = "${@bb.utils.contains('AGL_FEATURES', 'kingfisher', '-kf', '', d)}"
-
python __anonymous() {
for c in (d.getVar('GUEST_IMAGES') or "").split():
(mc, image) = c.split(':')
@@ -56,7 +53,7 @@ install_guest_images() {
name=${image}
rm -rf ${IMAGE_ROOTFS}/var/lib/machines/${name}
install -m 0755 -d ${IMAGE_ROOTFS}/var/lib/machines/${name}
- src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}${MACHINE_SUFFIX}.ext4"
+ src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}.ext4"
bbnote "Installing ${src}"
install -m 0600 ${src} ${IMAGE_ROOTFS}/var/lib/machines/${name}/
# Placeholder until booting from kernel in VM image is worked out