summaryrefslogtreecommitdiffstats
path: root/recipes-sdl
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-05-15 14:47:00 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2018-06-05 15:11:36 +0200
commitb6852864508358930586e083e72cd2912af68674 (patch)
tree4029e33f00bbd0247524d03f7c1689672d85ef9b /recipes-sdl
parentfab778caff2041794814df54b51893965381aa66 (diff)
3rd part of the layer/profile rework [2/2]
This is the last part of the layer rework series. Notable changes are: - move demo specific recipes to the demo (dlt, web-runtime mocca-usb) - wayland-ivi-extension moved to the meta-agl-demo layer for now. - web-runtime moved here (from appfw layer to allow console-only builds with appfw) - adapted packagegroups and agl-features v2: squashed with commit on sandbox to form single commit (tnx, Scott) v3: inclusion of old packagegroup-agl-image-ivi (TODO: refactor and include in profile packagegroups. Tnx, Stephane) v4: base packagegroup-agl-demo-platform on packagegroup-agl-profile-graphical-qt5 v5: fix MOST_DRIVERS_append (disable due to FTBS) v6: re-add RDEPENDS for virtual/pulseaudio-config Bug-AGL: SPEC-145 Bug-AGL: SPEC-1422 Change-Id: I20bd5b9a957ea54a7ecd08bd4f8b99a32266c9c8 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'recipes-sdl')
-rw-r--r--recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
new file mode 100644
index 00000000..7d135356
--- /dev/null
+++ b/recipes-sdl/packagegroups/packagegroup-agl-smartdevicelink.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Set of packages for SmartDeviceLink"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-smartdevicelink \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ sdl-core \
+ "
+
+# Porter does not have the required gstreamer version
+RDEPENDS_${PN}_porter := ""