summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo/mediaplayer/mediaplayer_git.bb22
-rw-r--r--recipes-demo/messaging/messaging_git.bb22
-rw-r--r--recipes-demo/phone/phone_git.bb22
-rw-r--r--recipes-demo/radio/files/presets-ALS.conf12
-rw-r--r--recipes-demo/radio/files/presets-CES.conf14
-rw-r--r--recipes-demo/radio/files/presets-FOSDEM.conf14
-rw-r--r--recipes-demo/radio/radio_git.bb36
-rw-r--r--recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb4
8 files changed, 146 insertions, 0 deletions
diff --git a/recipes-demo/mediaplayer/mediaplayer_git.bb b/recipes-demo/mediaplayer/mediaplayer_git.bb
new file mode 100644
index 00000000..7962f76c
--- /dev/null
+++ b/recipes-demo/mediaplayer/mediaplayer_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Media Player application"
+DESCRIPTION = "AGL demonstration Media Player application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/mediaplayer"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 libqtappfw"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += "libqtappfw mpd"
diff --git a/recipes-demo/messaging/messaging_git.bb b/recipes-demo/messaging/messaging_git.bb
new file mode 100644
index 00000000..47b3be8e
--- /dev/null
+++ b/recipes-demo/messaging/messaging_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Messaging application"
+DESCRIPTION = "AGL demonstration Messaging application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/messaging"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += "libqtappfw"
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
new file mode 100644
index 00000000..5e89af53
--- /dev/null
+++ b/recipes-demo/phone/phone_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phone application"
+DESCRIPTION = "AGL demonstration Phone application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
+
+RDEPENDS:${PN} += "libqtappfw"
diff --git a/recipes-demo/radio/files/presets-ALS.conf b/recipes-demo/radio/files/presets-ALS.conf
new file mode 100644
index 00000000..ff559227
--- /dev/null
+++ b/recipes-demo/radio/files/presets-ALS.conf
@@ -0,0 +1,12 @@
+[fmPresets]
+1\frequency=76100000
+1\title=Inter FM
+2\frequency=77100000
+2\title=The Open University of Japan
+3\frequency=80000000
+3\title=TOKYO FM
+4\frequency=81300000
+4\title=J-WAVE
+5\frequency=82500000
+5\title=NHK FM Tokyo
+size=5
diff --git a/recipes-demo/radio/files/presets-CES.conf b/recipes-demo/radio/files/presets-CES.conf
new file mode 100644
index 00000000..83caeffe
--- /dev/null
+++ b/recipes-demo/radio/files/presets-CES.conf
@@ -0,0 +1,14 @@
+[fmPresets]
+1\frequency=93100000
+1\title=93.1 The Mountain
+2\frequency=94100000
+2\title=Mix 94.1
+3\frequency=96300000
+3\title=96.3 KKLZ
+4\frequency=102700000
+4\title=102.7 THE COYOTE
+5\frequency=88900000
+5\title=News 88.9
+6\frequency=91500000
+6\title=KUNV
+size=6
diff --git a/recipes-demo/radio/files/presets-FOSDEM.conf b/recipes-demo/radio/files/presets-FOSDEM.conf
new file mode 100644
index 00000000..b88364f7
--- /dev/null
+++ b/recipes-demo/radio/files/presets-FOSDEM.conf
@@ -0,0 +1,14 @@
+[fmPresets]
+1\frequency=92100000
+1\title=92.1 Radio Campus
+2\frequency=92500000
+2\title=92.5 RTBF La Première
+3\frequency=93200000
+3\title=93.2 RTBF Classic 21
+4\frequency=98800000
+4\title=98.8 FM Brussel
+5\frequency=103700000
+5\title=103.7 NRJ
+6\frequency=104000000
+6\title=104.0 Bel RTL
+size=6
diff --git a/recipes-demo/radio/radio_git.bb b/recipes-demo/radio/radio_git.bb
new file mode 100644
index 00000000..e4dd07c7
--- /dev/null
+++ b/recipes-demo/radio/radio_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Radio application"
+DESCRIPTION = "AGL demonstration Radio application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0 & GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;branch=${AGL_BRANCH} \
+ file://presets-ALS.conf \
+ file://presets-CES.conf \
+ file://presets-FOSDEM.conf \
+"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+# ALS, CES, FOSDEM available
+AGL_RADIO_PRESETS_LOCALE ?= "CES"
+do_install:append() {
+ install -d ${D}${sysconfdir}/xdg/AGL
+ install -m 0644 ${WORKDIR}/presets-CES.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-CES.conf
+ install -m 0644 ${WORKDIR}/presets-ALS.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-ALS.conf
+ install -m 0644 ${WORKDIR}/presets-FOSDEM.conf ${D}${sysconfdir}/xdg/AGL/radio-presets-FOSDEM.conf
+ install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
+}
+
+FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
+
+RDEPENDS:${PN} += "libqtappfw"
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
index fcb31d9e..a86da2e2 100644
--- a/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
+++ b/recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
@@ -28,6 +28,10 @@ AGL_APPS = " \
hvac \
ondemandnavi \
settings \
+ mediaplayer \
+ messaging \
+ phone \
+ radio \
"
# Hook for demo platform configuration