summaryrefslogtreecommitdiffstats
path: root/recipes-demo/phone/phone_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-demo/phone/phone_git.bb')
-rw-r--r--recipes-demo/phone/phone_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
new file mode 100644
index 00000000..5e89af53
--- /dev/null
+++ b/recipes-demo/phone/phone_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phone application"
+DESCRIPTION = "AGL demonstration Phone application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
+
+RDEPENDS:${PN} += "libqtappfw"