summaryrefslogtreecommitdiffstats
path: root/recipes-demo/phone/phone_git.bb
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-02-15 18:20:56 -0500
committerScott Murray <scott.murray@konsulko.com>2022-02-21 15:52:23 +0000
commit5f46a8150d790f6bd897e3d759c8e3abf65da9cd (patch)
tree3c245433deebefb597de8c7a5c0b2df0090dba5d /recipes-demo/phone/phone_git.bb
parent4e90b52b2663a35a2c176c911d23c91864f4d26f (diff)
Add mediaplayer, radio, phone, and messaging apps back
Add updated recipes for the mediaplayer, radio, phone, and messaging apps that build the updated versions that do not use the previous application framework. The mediaplayer currently only has local media playback support via libqtappfw, the other apps are somewhat placeholders for now as their application framework usage via libqtappfw has been stubbed out for now. Bug-AGL: SPEC-4182 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia7aca1698a7e2c8381d4e257d447bcfbe3bce42e
Diffstat (limited to 'recipes-demo/phone/phone_git.bb')
-rw-r--r--recipes-demo/phone/phone_git.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-demo/phone/phone_git.bb b/recipes-demo/phone/phone_git.bb
new file mode 100644
index 00000000..5e89af53
--- /dev/null
+++ b/recipes-demo/phone/phone_git.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Phone application"
+DESCRIPTION = "AGL demonstration Phone application"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
+
+PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
+
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
+
+RDEPENDS:${PN} += "libqtappfw"