summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-demo-hmi/onscreenapp/onscreenapp_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb b/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
new file mode 100644
index 00000000..ae905ea6
--- /dev/null
+++ b/recipes-demo-hmi/onscreenapp/onscreenapp_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "onscreenapp for displaying onscreen"
+DESCRIPTION = "AGL HMI Application for displaying onscreen"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/onscreenapp"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/onscreenapp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 libhomescreen qlibhomescreen libwindowmanager qlibwindowmanager"
+
+inherit qmake5 aglwgt