summaryrefslogtreecommitdiffstats
path: root/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
committerScott Murray <scott.murray@konsulko.com>2021-08-20 13:57:33 -0400
commit37d3b1b316470fdcfebc59d5522bfbfefc025ff6 (patch)
treecf70d6c9e3832d8734de4f66f2d0fe52b104c9fd /meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp
parentab5f7f52dbdbea04d1f79310cbf08922a5371345 (diff)
Convert to new override syntax
This is mostly the result of running a slightly customized version of the convert-overrides.py script from poky with additional overrides added. A few minor fixups were done by hand afterwards during a review of the changes. The intent of these changes is to minimize the effort to keep the "next" branch that builds against poky master up to date and tested in preparation for the switch to the next Yocto LTS release in early 2022. Bug-AGL: SPEC-4052 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I0bbae97331abee1367b368ce54ab39e3162a12ec
Diffstat (limited to 'meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp')
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend2
-rw-r--r--meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend2
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
index 687980cf..ce7b0227 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
@@ -1,5 +1,5 @@
-do_deploy_append_raspberrypi4() {
+do_deploy:append:raspberrypi4() {
# if ARMSTUB is set, it should be set in config.txt by earlier recipes, so replace it
if [ -n "${ARMSTUB}" ]; then
sed -i 's/^armstub=.*/armstub=bl31.bin/' ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
diff --git a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 158eb6e8..e84d2409 100644
--- a/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/meta-agl-jailhouse/dynamic-layers/raspberrypi/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -6,7 +6,7 @@ TFA_PLATFORM = "rpi4"
# partition that is generated from the files in DEPLOYDIR
do_install[noexec] = "1"
-FILES_${PN} = ""
+FILES:${PN} = ""
do_deploy() {
if ${@"true" if d.getVar('TFA_DEBUG') == '1' else "false"}; then