summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-05-13 14:41:41 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-13 10:47:39 +0000
commiteb1cb6e454c2355d64238683d2111f5da4964706 (patch)
tree7fd4f2a22d1c085cf947be90379afdddbe9da028 /meta-oem-production-readiness
parent9e91874e6e23eb36570653aaf93e0d4d994d90bc (diff)
Replace "/etc" with "${sysconfidir}"
make them more standardized v2: also update ${D}/lib -> ${D}${libdir} v3: updated FILES sections as well Bug-AGL: SPEC-4374 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Ia2809d849ba9424aa54bab5b651c07b24d3a5cee
Diffstat (limited to 'meta-oem-production-readiness')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb
index a918ee0b..39f6902d 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-core/agl-systemd/agl-systemd_1.0.0.bb
@@ -14,10 +14,10 @@ do_configure[noexec] = "1"
do_compile[noexec] = "1"
do_install() {
- install -d ${D}/etc/systemd/system/
- install -m 644 ${S}/launch_sm.service ${D}/etc/systemd/system/
- install -m 644 ${S}/systemd-udev-trigger.service ${D}/etc/systemd/system/
- install -m 644 ${S}/setup_refhw.service ${D}/etc/systemd/system/
+ install -d ${D}${sysconfdir}/systemd/system/
+ install -m 644 ${S}/launch_sm.service ${D}${sysconfdir}/systemd/system/
+ install -m 644 ${S}/systemd-udev-trigger.service ${D}${sysconfdir}/systemd/system/
+ install -m 644 ${S}/setup_refhw.service ${D}${sysconfdir}/systemd/system/
install -d ${D}${CONFDIR}/
install -m 644 ${S}/env.txt ${D}${CONFDIR}/
@@ -25,8 +25,8 @@ do_install() {
install -d ${D}${bindir}
install -m 755 ${S}/tool_9E_SI/*.sh ${D}${bindir}/
- install -d ${D}/lib/udev/rules.d
- install -m 644 ${S}/99-basesystem.rules ${D}/lib/udev/rules.d/
+ install -d ${D}${libdir}/udev/rules.d
+ install -m 644 ${S}/99-basesystem.rules ${D}/${libdir}/udev/rules.d/
}
RDEPENDS:${PN} += "bash"