summaryrefslogtreecommitdiffstats
path: root/meta-oem-production-readiness
diff options
context:
space:
mode:
authorRiku Nomoto <riku.nomoto@woven-planet.global>2020-11-26 23:12:10 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-01-14 16:29:30 +0000
commitfdf2a2eb9ac9e6d71643ec12cde326f4ddd30813 (patch)
treefcc0ce1e3a88d036b86127891aa26411d19d0f56 /meta-oem-production-readiness
parent5238d28c0c8924e6d441337e169458c18f3cc6a2 (diff)
oem-pr-bs: add communication libraries
This is the fifth commit of agl-basesystem. Communication libraries v13 (jsmoeller): fix build of multiple packages v19 (nomoto): change mail address and author Bug-AGL: SPEC-3670 Signed-off-by: Riku Nomoto <riku.nomoto@woven-planet.global> Change-Id: I18fdf9bd59c71a02de5a592d694fd06ffddbd997
Diffstat (limited to 'meta-oem-production-readiness')
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-service.bb1
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationsubcpu/ps-communicationsubcpu_1.0.0.bb20
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationusb/ps-communicationusb_1.0.0.bb18
-rw-r--r--meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ps-communication/ps-communication_1.0.0.bb26
4 files changed, 65 insertions, 0 deletions
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-service.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-service.bb
index 36941dee..a7cf249c 100644
--- a/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-service.bb
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-platform/packagegroups/packagegroup-agl-basesystem-service.bb
@@ -14,4 +14,5 @@ RDEPENDS_${PN} += " \
os-posixbasedos001legacylibrary \
os-rpclibrary \
os-eventlibrary \
+ ps-communication \
"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationsubcpu/ps-communicationsubcpu_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationsubcpu/ps-communicationsubcpu_1.0.0.bb
new file mode 100644
index 00000000..1257dce0
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationsubcpu/ps-communicationsubcpu_1.0.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "ps-communicationsubcpu for AGL software"
+DESCRIPTION = "ps-communicationsubcpu to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified \
+ evklib-headers \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/stub/communication_subcpu"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile"
+
+FILES_${PN} += "${libdir}/*"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationusb/ps-communicationusb_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationusb/ps-communicationusb_1.0.0.bb
new file mode 100644
index 00000000..6acd54d2
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-stub/ps-communicationusb/ps-communicationusb_1.0.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "ps-communicationusb for AGL software"
+DESCRIPTION = "ps-communicationusb to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " ns-frameworkunified"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/stub/communication_usb"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile"
+
+FILES_${PN} += "${libdir}/*"
diff --git a/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ps-communication/ps-communication_1.0.0.bb b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ps-communication/ps-communication_1.0.0.bb
new file mode 100644
index 00000000..39895478
--- /dev/null
+++ b/meta-oem-production-readiness/meta-agl-basesystem/recipes-support/ps-communication/ps-communication_1.0.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "ps-communication for AGL software"
+DESCRIPTION = "ps-communication to build AGL software"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
+
+DEPENDS += " \
+ ns-frameworkunified \
+ ps-communicationsubcpu \
+"
+
+PV = "1.0.0+gitr${SRCPV}"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/basesystem.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV := "${BASESYSTEM_REVISION}"
+
+S = "${WORKDIR}/git/service/peripheral/communication"
+
+inherit agl-basesystem-common
+
+BSMAKE_FILE = "Makefile.client"
+
+FILES_${PN} += "${libdir}/*"
+
+RDEPENDS_${PN} += " \
+ ns-frameworkunified \
+ ps-communicationsubcpu \
+"