aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-05-03 14:32:50 -0400
committerScott Murray <scott.murray@konsulko.com>2022-05-03 14:35:22 -0400
commita3fc369d430c7f0c530d10c5692817edde8d276c (patch)
treeefdacfe13672bfa5aef5fccbf65dce9390432b85
parent27785f1c4d0f9de2025a5ba9504651fb651f74d1 (diff)
wlconf: fix behavior with usrmerge
The do_install in the wlconf recipe was hard-coding /lib in a few places instead of using ${nonarch_base_libdir}, which results in packaging failures when using the usrmerge distro feature, properly use ${nonarch_base_libdir} where required. Bug-AGL: SPEC-4352 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I6756e0fbb9f5ff23dda5cd57229283a9c8686d74
-rw-r--r--meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb b/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
index 477c5a9..a6f6223 100644
--- a/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
+++ b/meta-agl-refhw-gen3/recipes-connectivity/wlconf/wlconf_8.7.3.bb
@@ -14,14 +14,14 @@ do_install() {
install -d ${D}${sbindir}
install -d ${D}${sbindir}/wlconf/
install -d ${D}${sbindir}/wlconf/official_inis
- install -d ${D}/lib/firmware/ti-connectivity
+ install -d ${D}${nonarch_base_libdir}/firmware/ti-connectivity
install -m 0755 wlconf ${D}${sbindir}/wlconf/
install -m 0755 dictionary.txt ${D}${sbindir}/wlconf/
install -m 0755 struct.bin ${D}${sbindir}/wlconf/
install -m 0755 default.conf ${D}${sbindir}/wlconf/
install -m 0755 wl18xx-conf-default.bin ${D}${sbindir}/wlconf/
- install -m 0755 wl18xx-conf-default.bin ${D}/lib/firmware/ti-connectivity/wl18xx-conf.bin
+ install -m 0755 wl18xx-conf-default.bin ${D}${nonarch_base_libdir}/firmware/ti-connectivity/wl18xx-conf.bin
install -m 0755 README ${D}${sbindir}/wlconf/
install -m 0755 example.conf ${D}${sbindir}/wlconf/
install -m 0755 example.ini ${D}${sbindir}/wlconf/
@@ -33,7 +33,7 @@ do_install() {
FILES:${PN} += " \
${sbindir}/wlconf \
${sbindir}/wlconf/official_inis \
- /lib/firmware/ti-connectivity/wl18xx-conf.bin \
+ ${nonarch_base_libdir}/firmware/ti-connectivity/wl18xx-conf.bin \
"
FILES:${PN}-dbg += "${sbindir}/wlconf/.debug"