summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Bollo <jose.bollo@iot.bzh>2018-01-24 11:18:02 +0100
committerJosé Bollo <jose.bollo@iot.bzh>2018-02-13 11:02:00 +0100
commit3f962c7d202055777dd0238f12dbcf70f09ac07d (patch)
tree0ad4b25c99084b44e2718f9b0df344c98cc1261b
parent511f7ee40552cccc44a387eb93c9681c2243147e (diff)
Rename smack OVERRIDE to with-lsm-smack
Using the OVERRIDE "smack" came with the use of the layer meta-intel-iot-security. When switching to meta-security, it conflicts with the package name 'smack' that provide the smack user library. Yocto was reporting the following error: ERROR: .../meta-security/recipes-security/smack/smack_1.3.0.bb: QA Issue: Recipe .../meta-security/recipes-security/smack/smack_1.3.0.bb has PN of "smack" which is in OVERRIDES, this can result in unexpected behaviour. [pn-overrides] Change-Id: Id71b283bf1ce5682bd94bf96595eb32506acb1d5 Signed-off-by: José Bollo <jose.bollo@iot.bzh>
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend2
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-agl-4.9.inc2
-rw-r--r--meta-agl-bsp/recipes-kernel/linux/linux-agl.inc2
-rw-r--r--meta-app-framework/conf/include/agl-appfw-smack.inc2
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.bb8
-rw-r--r--meta-app-framework/recipes-core/base-files/base-files_%.bbappend8
-rw-r--r--meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend2
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux-%.bbappend2
-rw-r--r--meta-app-framework/recipes-kernel/linux/linux-yocto_4.12.bbappend2
-rw-r--r--templates/feature/agl-appfw-smack/50_bblayers.conf.inc5
10 files changed, 18 insertions, 17 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
index 5d5549f0a..3da7180e6 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
@@ -13,6 +13,6 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cgroup.cfg"
#-------------------------------------------------------------------------
# smack patches for handling bluetooth
-SRC_URI_append_smack = "\
+SRC_URI_append_with-lsm-smack = "\
file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
"
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-agl-4.9.inc b/meta-agl-bsp/recipes-kernel/linux/linux-agl-4.9.inc
index 3235ff4d1..c4ebf4d46 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-agl-4.9.inc
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-agl-4.9.inc
@@ -3,6 +3,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-4.9:"
#-------------------------------------------------------------------------
# smack patches for handling bluetooth
-SRC_URI_append_smack = "\
+SRC_URI_append_with-lsm-smack = "\
file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
"
diff --git a/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc b/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc
index db37ab2f5..b6f9604a5 100644
--- a/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc
+++ b/meta-agl-bsp/recipes-kernel/linux/linux-agl.inc
@@ -67,7 +67,7 @@ SRC_URI_append_virtualmachine = " file://vbox-vmware-sata.cfg"
KERNEL_CONFIG_FRAGMENTS_append_virtualmachine = " ${WORKDIR}/vbox-vmware-sata.cfg"
# Enable support for smack
-KERNEL_CONFIG_FRAGMENTS_append_smack = "\
+KERNEL_CONFIG_FRAGMENTS_append_with-lsm-smack = "\
${WORKDIR}/audit.cfg \
${WORKDIR}/smack.cfg \
${WORKDIR}/smack-default-lsm.cfg \
diff --git a/meta-app-framework/conf/include/agl-appfw-smack.inc b/meta-app-framework/conf/include/agl-appfw-smack.inc
index b77a5d17c..95092a9ce 100644
--- a/meta-app-framework/conf/include/agl-appfw-smack.inc
+++ b/meta-app-framework/conf/include/agl-appfw-smack.inc
@@ -1,5 +1,5 @@
# enable security features (smack, cynara) - required by Application Framework
-OVERRIDES .= ":smack"
+OVERRIDES .= ":with-lsm-smack"
DISTRO_FEATURES_append = " smack dbus-cynara xattr"
# use tar-native to support SMACK extended attributes independently of host config
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
index 8ac661527..69df39eae 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.bb
@@ -14,7 +14,7 @@ DEPENDS = "openssl libxml2 xmlsec1 systemd libzip json-c systemd security-manage
DEPENDS_class-native = "openssl libxml2 xmlsec1 libzip json-c"
RDEPENDS_${PN}_class-target += "af-binder-tools"
-PACKAGE_WRITE_DEPS_append_smack = " smack-userspace-native libcap-native"
+PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-userspace-native libcap-native"
EXTRA_OECMAKE_class-native = "\
-DUSE_LIBZIP=1 \
@@ -46,8 +46,8 @@ GROUPADD_PARAM_${PN} = "-r ${afm_name}"
FILES_${PN} += "\
${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/afm-user-daemon.service', '', d)} \
"
-RDEPENDS_${PN}_append_smack = " smack-userspace bash"
-DEPENDS_append_smack = " smack-userspace-native"
+RDEPENDS_${PN}_append_with-lsm-smack = " smack-userspace bash"
+DEPENDS_append_with-lsm-smack = " smack-userspace-native"
# short hacks here
SRC_URI += "\
@@ -90,7 +90,7 @@ pkg_postinst_${PN}() {
chown ${afm_name}:${afm_name} $D${afm_datadir}/icons
}
-pkg_postinst_${PN}_append_smack() {
+pkg_postinst_${PN}_append_with-lsm-smack() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
chsmack -a 'System::Shared' -t $D${systemd_units_root}/system
chsmack -a 'System::Shared' -t $D${systemd_units_root}/system/afm-user-session@.target.wants
diff --git a/meta-app-framework/recipes-core/base-files/base-files_%.bbappend b/meta-app-framework/recipes-core/base-files/base-files_%.bbappend
index 636bcc4df..249f32156 100644
--- a/meta-app-framework/recipes-core/base-files/base-files_%.bbappend
+++ b/meta-app-framework/recipes-core/base-files/base-files_%.bbappend
@@ -1,5 +1,5 @@
-RDEPENDS_${PN}_append_smack = " smack-userspace"
-PACKAGE_WRITE_DEPS_append_smack = " smack-userspace-native"
+RDEPENDS_${PN}_append_with-lsm-smack = " smack-userspace"
+PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-userspace-native"
do_install_append() {
install -d ${D}/${sysconfdir}/skel/app-data
@@ -13,7 +13,7 @@ do_install_append() {
ln -s ../../var/local ${D}/usr/local
}
-do_install_append_smack () {
+do_install_append_with-lsm-smack () {
install -d ${D}/${sysconfdir}/smack/accesses.d
cat > ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user <<EOF
System User::App-Shared rwxat
@@ -22,7 +22,7 @@ EOF
chmod 0644 ${D}/${sysconfdir}/smack/accesses.d/default-access-domains-no-user
}
-pkg_postinst_${PN}_append_smack() {
+pkg_postinst_${PN}_append_with-lsm-smack() {
chsmack -r -a 'User::Home' -t -D $D/${sysconfdir}/skel
chsmack -a 'User::App-Shared' -D $D/${sysconfdir}/skel/app-data
cp -rTf --preserve=all $D/${sysconfdir}/skel $D/${ROOT_HOME}
diff --git a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
index 92b79572f..cd02afabb 100644
--- a/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
+++ b/meta-app-framework/recipes-core/security-manager/security-manager_%.bbappend
@@ -1,6 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/security-manager:"
-PACKAGE_WRITE_DEPS_append_smack = " smack-userspace-native"
+PACKAGE_WRITE_DEPS_append_with-lsm-smack = " smack-userspace-native"
SRC_URI += " file://0001-Adapt-rules-to-AGL.patch \
file://init-security-manager-db.service \
diff --git a/meta-app-framework/recipes-kernel/linux/linux-%.bbappend b/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
index 02595efdf..fba5bf13d 100644
--- a/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
+++ b/meta-app-framework/recipes-kernel/linux/linux-%.bbappend
@@ -1,3 +1,3 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"
-SRC_URI_append_smack = " file://audit.cfg"
+SRC_URI_append_with-lsm-smack = " file://audit.cfg"
diff --git a/meta-app-framework/recipes-kernel/linux/linux-yocto_4.12.bbappend b/meta-app-framework/recipes-kernel/linux/linux-yocto_4.12.bbappend
index b1eadaffa..5ae62d586 100644
--- a/meta-app-framework/recipes-kernel/linux/linux-yocto_4.12.bbappend
+++ b/meta-app-framework/recipes-kernel/linux/linux-yocto_4.12.bbappend
@@ -3,7 +3,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux/linux-yocto-4.12:"
#-------------------------------------------------------------------------
# smack patches for handling bluetooth
-SRC_URI_append_smack = "\
+SRC_URI_append_with-lsm-smack = "\
file://0002-smack-fix-cache-of-access-labels.patch \
file://0003-Smack-ignore-null-signal-in-smack_task_kill.patch \
file://0004-Smack-Assign-smack_known_web-label-for-kernel-thread.patch \
diff --git a/templates/feature/agl-appfw-smack/50_bblayers.conf.inc b/templates/feature/agl-appfw-smack/50_bblayers.conf.inc
index 344c25070..7f5f24eb5 100644
--- a/templates/feature/agl-appfw-smack/50_bblayers.conf.inc
+++ b/templates/feature/agl-appfw-smack/50_bblayers.conf.inc
@@ -1,6 +1,7 @@
BBLAYERS =+ " \
- ${METADIR}/meta-intel-iot-security/meta-security-smack \
- ${METADIR}/meta-intel-iot-security/meta-security-framework \
+ ${METADIR}/meta-security \
+ ${METADIR}/meta-openembedded/meta-perl \
+ ${METADIR}/meta-agl/meta-security \
${METADIR}/meta-agl/meta-app-framework \
"