summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorduerpei <duep.fnst@fujitsu.com>2022-05-16 11:10:07 +0800
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-05-16 12:10:15 +0000
commit52c2394ca9ce54c5117da40ab9a0e7eebf8db7d4 (patch)
tree71f424b2ad9b42f3cc11f1e27018b2980be1f478
parentba35313c0852ebaf924a9b71d87a4e3f5e90ac9b (diff)
Replace "/etc" with "${sysconfidir}"
make them more standardized Bug-AGL: SPEC-4374 Signed-off-by: duerpei <duep.fnst@fujitsu.com> Change-Id: Ie11168254ab76acd11382b33501fb4881710a5bf Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/27479 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend4
-rw-r--r--meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb6
2 files changed, 5 insertions, 5 deletions
diff --git a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
index 3f497a1be..86e353414 100644
--- a/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
+++ b/meta-agl-bsp/meta-ti-bsp/recipes-graphics/libgles/ti-sgx-ddk-um_%.bbappend
@@ -13,6 +13,6 @@ SYSTEMD_SERVICE:${PN} = "pvr.service"
do_install:append() {
install -d ${D}${systemd_system_unitdir}
install -m 0755 ${WORKDIR}/pvr.service ${D}${systemd_system_unitdir}
- install -d ${D}/etc/ti-sgx
- install -m 0755 ${D}/etc/init.d/rc.pvr ${D}/etc/ti-sgx
+ install -d ${D}${sysconfdir}/ti-sgx
+ install -m 0755 ${D}${sysconfdir}/init.d/rc.pvr ${D}${sysconfdir}/ti-sgx
}
diff --git a/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb b/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
index 1e3ae7f76..dd61a1ea8 100644
--- a/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
+++ b/meta-netboot/recipes-core/initramfs-netboot/initramfs-netboot_1.0.bb
@@ -8,8 +8,8 @@ S = "${WORKDIR}"
RDEPENDS:${PN} += "nbd-client"
do_install() {
- install -dm 0755 ${D}/etc
- touch ${D}/etc/initrd-release
+ install -dm 0755 ${D}${sysconfdir}
+ touch ${D}${sysconfdir}/initrd-release
install -dm 0755 ${D}/dev
install -dm 0755 ${D}${sbindir}
install -m 0755 ${WORKDIR}/init.sh ${D}${sbindir}/init
@@ -17,5 +17,5 @@ do_install() {
inherit allarch
-FILES:${PN} += " /dev /etc/initrd-release ${sbindir}/init "
+FILES:${PN} += " /dev ${sysconfdir}/initrd-release ${sbindir}/init "