summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-10-28 19:07:32 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-10-31 17:58:12 +0000
commit59bf470bc3f870791f349691c1238c0f6c5b9704 (patch)
tree9dae4b6f4ebf1a2d6f6e483cb722279ccda22e9e
parent202d801eb83c456ee44a15ccf6142e7d23a80cbc (diff)
Use kernel_configure_variable in append for rpi
This changeset simplifies the configuration of the rpi kernel by using kernel_configure_variable in do_configure_append. Due to an upstream bug, we need to repeat the final configuration call. We also enable BLK_DEV_RAM, BLK_DEV_NBD and SMACK. For this we also define an OVERRIDE for netboot. v2: add conditional appends for netboot, sota, smack by using overrides. Change-Id: I2a4a8fae6989246d715fc2fc71bb4c251f423bdb Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-rpi-defconfig.patch42
-rw-r--r--meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend47
-rw-r--r--templates/feature/agl-netboot/50_local.conf.inc1
3 files changed, 47 insertions, 43 deletions
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-rpi-defconfig.patch b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-rpi-defconfig.patch
deleted file mode 100644
index ab6863b9f..000000000
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi/0001-rpi-defconfig.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 34f9f2a5b83869a8620d6bc212dc7110a75202ac Mon Sep 17 00:00:00 2001
-From: Changhyeok Bae <changhyeok.bae@lge.com>
-Date: Thu, 11 Aug 2016 00:44:08 +0900
-Subject: [PATCH] rpi defconfig
-
----
- arch/arm/configs/bcm2709_defconfig | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/arch/arm/configs/bcm2709_defconfig b/arch/arm/configs/bcm2709_defconfig
-index 3eff0fc..5859b1d 100644
---- a/arch/arm/configs/bcm2709_defconfig
-+++ b/arch/arm/configs/bcm2709_defconfig
-@@ -607,6 +607,7 @@ CONFIG_I2C=y
- CONFIG_I2C_CHARDEV=m
- CONFIG_I2C_MUX_PCA954x=m
- CONFIG_I2C_BCM2708=m
-+CONFIG_I2C_BCM2835=y
- CONFIG_I2C_GPIO=m
- CONFIG_SPI=y
- CONFIG_SPI_BCM2835=m
-@@ -818,14 +819,14 @@ CONFIG_VIDEO_TW9903=m
- CONFIG_VIDEO_TW9906=m
- CONFIG_VIDEO_OV7640=m
- CONFIG_VIDEO_MT9V011=m
--CONFIG_DRM=m
-+CONFIG_DRM=y
- CONFIG_DRM_LOAD_EDID_FIRMWARE=y
- CONFIG_DRM_UDL=m
- CONFIG_DRM_PANEL_SIMPLE=m
--CONFIG_DRM_PANEL_RASPBERRYPI_TOUCHSCREEN=m
--CONFIG_DRM_VC4=m
-+CONFIG_DRM_PANEL_RASPBERRYPI_TOUCHSCREEN=y
-+CONFIG_DRM_VC4=y
- CONFIG_FB=y
--CONFIG_FB_BCM2708=y
-+# CONFIG_FB_BCM2708 is not set
- CONFIG_FB_UDL=m
- CONFIG_FB_SSD1307=m
- CONFIG_FB_RPISENSE=m
---
-2.9.0
diff --git a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
index 8c0073538..f7b12e065 100644
--- a/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
+++ b/meta-agl-bsp/meta-raspberrypi/recipes-kernel/linux/linux-raspberrypi_4.4.bbappend
@@ -5,10 +5,55 @@ LINUX_VERSION = "4.4.16"
SRCREV = "26550dcfb86b0308a99f726abbfb55abb1b0f78c"
SRC_URI_append = "\
- file://0001-rpi-defconfig.patch \
${@base_conditional('USE_FAYTECH_MONITOR', '1', 'file://0002-faytech-fix-rpi.patch', '', d)} \
"
+do_configure_append_smack() {
+ # SMACK and Co
+ kernel_configure_variable IP_NF_SECURITY m
+ kernel_configure_variable IP6_NF_SECURITY m
+ kernel_configure_variable EXT2_FS_SECURITY y
+ kernel_configure_variable EXT3_FS_SECURITY y
+ kernel_configure_variable EXT4_FS_SECURITY y
+ kernel_configure_variable SECURITY y
+ kernel_configure_variable SECURITY_SMACK y
+ kernel_configure_variable TMPFS_XATTR y
+ kernel_configure_variable DEFAULT_SECURITY "smack"
+ kernel_configure_variable DEFAULT_SECURITY_SMACK y
+ kernel_configure_variable FANOTIFY_ACCESS_PERMISSIONS y
+}
+
+do_configure_append_netboot() {
+ # NBD for netboot
+ kernel_configure_variable BLK_DEV_NBD y
+ # ramblk for inird
+ kernel_configure_variable BLK_DEV_RAM y
+}
+
+do_configure_append_sota() {
+ # ramblk for inird
+ kernel_configure_variable BLK_DEV_RAM y
+}
+
+do_configure_append() {
+
+ # VC4 Wayland/Weston
+ kernel_configure_variable I2C_BCM2835 y
+ kernel_configure_variable DRM y
+ kernel_configure_variable DRM_PANEL_RASPBERRYPI_TOUCHSCREEN y
+ kernel_configure_variable DRM_VC4 y
+ kernel_configure_variable FB_BCM2708 n
+
+ # KEEP until fixed upstream:
+ # Keep this the last line
+ # Remove all modified configs and add the rest to .config
+ sed -e "${CONF_SED_SCRIPT}" < '${WORKDIR}/defconfig' >> '${B}/.config'
+
+ yes '' | oe_runmake oldconfig
+ kernel_do_configure
+}
+
+
CMDLINE_append = " usbhid.mousepoll=0"
KERNEL_MODULE_AUTOLOAD += "snd-bcm2835"
diff --git a/templates/feature/agl-netboot/50_local.conf.inc b/templates/feature/agl-netboot/50_local.conf.inc
index faff8f21c..47f0c08a6 100644
--- a/templates/feature/agl-netboot/50_local.conf.inc
+++ b/templates/feature/agl-netboot/50_local.conf.inc
@@ -1,4 +1,5 @@
INHERIT += "netboot"
+OVERRIDES .= ":netboot"
# add 256MB of extra space in ext4 output image
IMAGE_ROOTFS_EXTRA_SPACE ?= "262144"