summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Jahnke <tobias.jahnke@microchip.com>2019-08-15 11:26:01 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-08-20 14:35:15 +0000
commit66b7eba6ed5a7078bb438842e0e5276b5f192aa6 (patch)
tree128894bf48120028d462e6f177967a5c21c3a0fc
parentdeca451e6544ed4c735464b8846e6e70c0847c29 (diff)
Add recipe for agl-service-unicens-controller
Bug-AGL: SPEC-2738 Change-Id: I9612036c9bd35f4d1fe4fa00cb25f899b100e435 Signed-off-by: Tobias Jahnke <tobias.jahnke@microchip.com>
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb
new file mode 100644
index 000000000..85ebc90f6
--- /dev/null
+++ b/meta-agl-profile-core/recipes-apis/agl-service-unicens-controller/agl-service-unicens-controller_git.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Infotainment network device control"
+DESCRIPTION = "Abstraction layer to control INICnet devices"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-unicens-controller"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-unicens-controller;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit cmake aglwgt pkgconfig
+
+DEPENDS += "json-c af-binder libafb-helpers"
+RDEPENDS_${PN} += "agl-service-unicens"
+