summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Ranostay <matt.ranostay@konsulko.com>2019-05-02 12:13:27 +0300
committerMatt Ranostay <matt.ranostay@konsulko.com>2019-05-08 05:21:41 +0300
commit6852fd87706e22da8321691ef0018436eee6a1aa (patch)
tree04b61936959b3441fd1565a51d938317cb352cf6
parent639fffbe8e7f3756a543e2df1d1428d5c07601d7 (diff)
meta-agl-profile-core: recipes-apis: agl-service-bluetooth-map: add initial recipe
Add initial recipe for the Bluetooth MAP (Message Access Profile) binding. Bug-AGL: SPEC-2351 Change-Id: I9a40091f218e6ccef7af64aaed8d04b7cc605455 Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
-rw-r--r--meta-agl-profile-core/recipes-apis/agl-service-bluetooth-map/agl-service-bluetooth-map_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-apis/agl-service-bluetooth-map/agl-service-bluetooth-map_git.bb b/meta-agl-profile-core/recipes-apis/agl-service-bluetooth-map/agl-service-bluetooth-map_git.bb
new file mode 100644
index 000000000..bc53051f2
--- /dev/null
+++ b/meta-agl-profile-core/recipes-apis/agl-service-bluetooth-map/agl-service-bluetooth-map_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Bluetooth MAP Service Binding"
+DESCRIPTION = "AGL Bluetooth MAP Service Binding"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-bluetooth-map"
+SECTION = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-bluetooth-map;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+DEPENDS = "glib-2.0 json-c"
+RDEPENDS_${PN} = "bluez5-obex agl-service-bluetooth"
+
+inherit cmake aglwgt pkgconfig