summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-02-22 10:42:30 -0500
committerScott Murray <scott.murray@konsulko.com>2022-03-30 14:08:33 -0400
commit73c48ad8a6ec86af4dc87bc2a2679d2ce4566706 (patch)
treea8cde5a2bff33142c4cbc7547adfcf2504f56b15
parent9653de99a5452bb419f2f694553cfb66fabfbf01 (diff)
Update for kirkstone variable renames
Apply updates from running the new convert-variable-renames script from upstream, plus a few manual tweaks to the sample BB_DISKMON_DIRS configuration in the sample local.conf files to match the changes made in upstream. There are a few things outside of BitBake variables that the script still complains about that will need to be addressed in follow up changes. Bug-AGL: SPEC-3819 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I65e483043c1f2e48827e735cf8fdaec8d04e5fee
-rw-r--r--meta-agl-bsp/conf/include/agl_bbe.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_beaglebone.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi4.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc4
-rw-r--r--meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb2
-rw-r--r--meta-agl-core/conf/local.conf.sample10
-rwxr-xr-xscripts/.aglsetup_genconfig.bash6
-rw-r--r--templates/base/01_setup_pkg_revision.sh4
-rw-r--r--templates/base/local.conf.sample10
9 files changed, 21 insertions, 21 deletions
diff --git a/meta-agl-bsp/conf/include/agl_bbe.inc b/meta-agl-bsp/conf/include/agl_bbe.inc
index 9f9eb5039..d8b24a1a1 100644
--- a/meta-agl-bsp/conf/include/agl_bbe.inc
+++ b/meta-agl-bsp/conf/include/agl_bbe.inc
@@ -14,7 +14,7 @@ IMAGE_INSTALL:append = " ${PACKAGES_GFX}"
# Enable Gfx Pkgs
MACHINE_FEATURES:append = " sgx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
DEPENDS:remove = "virtual/libgl"
diff --git a/meta-agl-bsp/conf/include/agl_beaglebone.inc b/meta-agl-bsp/conf/include/agl_beaglebone.inc
index 857a801f3..6a515d2e5 100644
--- a/meta-agl-bsp/conf/include/agl_beaglebone.inc
+++ b/meta-agl-bsp/conf/include/agl_beaglebone.inc
@@ -9,7 +9,7 @@ IMAGE_INSTALL:append = " ${PACKAGES_GFX}"
# Enable Gfx Pkgs
MACHINE_FEATURES:append = " sgx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
DEPENDS:remove = "virtual/libgl"
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
index b497d72c8..3fdc68b2c 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
@@ -11,7 +11,7 @@ RPI_USE_U_BOOT = "1"
ENABLE_UART ?= "1"
# For libomxil
-#LICENSE_FLAGS_WHITELIST = "commercial"
+#LICENSE_FLAGS_ACCEPTED = "commercial"
IMAGE_INSTALL:append = " kernel-modules linux-firmware-rpidistro-bcm43430 linux-firmware-rpidistro-bcm43455 create-combined-dtb "
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index 6dc40dcb5..7f181fcb9 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -5,7 +5,7 @@ MACHINE_FEATURES:append = " agl-egvirt"
# Enable Gfx Pkgs
MACHINE_FEATURES:append = " gsx"
-MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
+BB_MULTI_PROVIDER_ALLOWED += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
# for Wayland/Weston
PREFERRED_PROVIDER_virtual/libgles1 = ""
@@ -20,7 +20,7 @@ PREFERRED_RPROVIDER_libomxil = "omx-user-module"
PREFERRED_PROVIDER_virtual/libomxil = "omx-user-module"
# Add for gstreamer plugins ugly
-LICENSE_FLAGS_WHITELIST = "commercial"
+LICENSE_FLAGS_ACCEPTED = "commercial"
MACHINE_FEATURES:append = " multimedia"
diff --git a/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb b/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
index 57a5d32e1..2f45f25d0 100644
--- a/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
+++ b/meta-agl-core-test/recipes-test/packagegroups/packagegroup-agl-test.bb
@@ -32,7 +32,7 @@ RDEPENDS:${PN} += "\
-# to be added, but needs LICENSE_FLAGS_WHITELIST="non-commercial"
+# to be added, but needs LICENSE_FLAGS_ACCEPTED="non-commercial"
# netperf # meta-networking
# relocate due to dependencies
diff --git a/meta-agl-core/conf/local.conf.sample b/meta-agl-core/conf/local.conf.sample
index 20a46ec8e..ecc9b141a 100644
--- a/meta-agl-core/conf/local.conf.sample
+++ b/meta-agl-core/conf/local.conf.sample
@@ -188,7 +188,7 @@ PATCHRESOLVE = "noop"
#
# Monitor the disk space during the build. If there is less that 1GB of space or less
# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard halt
# of the build. The reason for this is that running completely out of space can corrupt
# files and damages the build in ways which may not be easily recoverable.
# It's necesary to monitor /tmp, if there is no space left the build will fail
@@ -198,10 +198,10 @@ BB_DISKMON_DIRS ??= "\
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
- ABORT,${TMPDIR},100M,1K \
- ABORT,${DL_DIR},100M,1K \
- ABORT,${SSTATE_DIR},100M,1K \
- ABORT,/tmp,10M,1K"
+ HALT,${TMPDIR},100M,1K \
+ HALT,${DL_DIR},100M,1K \
+ HALT,${SSTATE_DIR},100M,1K \
+ HALT,/tmp,10M,1K"
#
# Shared-state files from other locations
diff --git a/scripts/.aglsetup_genconfig.bash b/scripts/.aglsetup_genconfig.bash
index cf06622ba..c7ed92e47 100755
--- a/scripts/.aglsetup_genconfig.bash
+++ b/scripts/.aglsetup_genconfig.bash
@@ -559,12 +559,12 @@ infon "Generating setup file: $BUILDDIR/agl-init-build-env ... "
cat <<EOF >$BUILDDIR/agl-init-build-env
. $METADIR/external/poky/oe-init-build-env $BUILDDIR
if [ -n "\$DL_DIR" ]; then
- BB_ENV_EXTRAWHITE="\$BB_ENV_EXTRAWHITE DL_DIR"
+ BB_ENV_PASSTHROUGH_ADDITIONS="\$BB_ENV_PASSTHROUGH_ADDITIONS DL_DIR"
fi
if [ -n "\$SSTATE_DIR" ]; then
- BB_ENV_EXTRAWHITE="\$BB_ENV_EXTRAWHITE SSTATE_DIR"
+ BB_ENV_PASSTHROUGH_ADDITIONS="\$BB_ENV_PASSTHROUGH_ADDITIONS SSTATE_DIR"
fi
-export BB_ENV_EXTRAWHITE
+export BB_ENV_PASSTHROUGH_ADDITIONS
unset TEMPLATECONF
EOF
info "OK"
diff --git a/templates/base/01_setup_pkg_revision.sh b/templates/base/01_setup_pkg_revision.sh
index cba278d18..a9e4ceb8c 100644
--- a/templates/base/01_setup_pkg_revision.sh
+++ b/templates/base/01_setup_pkg_revision.sh
@@ -36,7 +36,7 @@ EOF
cat <<'EOF' >> $LOCALCONF
PKGR = "${PR}${EXTENDPRAUTO}.${AGL_PR}"
PKGV = "${@ '${PV}'.replace('AUTOINC','${AGL_PR}')}"
-BB_HASHBASE_WHITELIST:append = " PKGR PKGV"
+BB_BASEHASH_IGNORE_VARS:append = " PKGR PKGV"
EOF
;;
value:*)
@@ -44,7 +44,7 @@ EOF
cat <<'EOF' >> $LOCALCONF
PKGR = "${PR}${EXTENDPRAUTO}.${AGL_PR}"
PKGV = "${@ '${PV}'.replace('AUTOINC','${AGL_PR}')}"
-BB_HASHBASE_WHITELIST:append = " PKGR PKGV"
+BB_BASEHASH_IGNORE_VARS:append = " PKGR PKGV"
EOF
;;
none)
diff --git a/templates/base/local.conf.sample b/templates/base/local.conf.sample
index 1d0044871..7f2c0b11a 100644
--- a/templates/base/local.conf.sample
+++ b/templates/base/local.conf.sample
@@ -186,7 +186,7 @@ PATCHRESOLVE = "noop"
#
# Monitor the disk space during the build. If there is less that 1GB of space or less
# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
+# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard halt
# of the build. The reason for this is that running completely out of space can corrupt
# files and damages the build in ways which may not be easily recoverable.
# It's necesary to monitor /tmp, if there is no space left the build will fail
@@ -196,10 +196,10 @@ BB_DISKMON_DIRS ??= "\
STOPTASKS,${DL_DIR},1G,100K \
STOPTASKS,${SSTATE_DIR},1G,100K \
STOPTASKS,/tmp,100M,100K \
- ABORT,${TMPDIR},100M,1K \
- ABORT,${DL_DIR},100M,1K \
- ABORT,${SSTATE_DIR},100M,1K \
- ABORT,/tmp,10M,1K"
+ HALT,${TMPDIR},100M,1K \
+ HALT,${DL_DIR},100M,1K \
+ HALT,${SSTATE_DIR},100M,1K \
+ HALT,/tmp,10M,1K"
#
# Shared-state files from other locations