summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-11-15 17:02:08 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-11-16 15:15:53 +0000
commit7bcb62f422876666f7a0f99bcf9ee92aa991c3b9 (patch)
tree5287a1a4a96327a4c5707cb54c4a863729efbce8
parentccd5efe68fd443bc7af549375780946d2317bbdf (diff)
meta-agl-profile-core: update pyagl SRCREV
Update pyagl SRCREV to pick up: 5aed9a3 Add marks for Internet requiring tests c18df01 Add simple wrapper script e1e2300 Add CAN value tests Also add installation of the new wrapper script as /usr/bin/pyagl. Bug-AGL: SPEC-3684, SPEC-3685 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I78ad81a0b11486929a038a83f9dd3487b875985f Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25578 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
index 18c963a2e..ab843065b 100644
--- a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
+++ b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
@@ -4,13 +4,17 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "8f44a95e7626e67cda3e3a05c3fa1a9298c02809"
+SRCREV = "5aed9a32ea71737709a11590d6ecc92f773f85d6"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
inherit setuptools3
+do_install_append() {
+ install -D -m 0755 ${S}/pyagl/scripts/pyagl ${D}${bindir}/pyagl
+}
+
RDEPENDS_${PN} += " \
python3-asyncio \
python3-asyncssh \