summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2022-11-22 03:27:32 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2022-11-23 14:04:04 +0000
commit91e60789323cc13d70ebe5355f7aa9668c3dcc34 (patch)
tree5d0122d489b090356a0627bea5c9afc84ad490d3
parent3274485826c6c1c719cdcff03ce3dbd2d8120ce8 (diff)
native-shell-client: Add recipe
Add recipe for native-shell-client simple agl-shell protocol client. It can be used for testing agl-compositor and also enables using it in simple usecases such as displaying the output from guest VMs with QEMU+KVM. Bug-AGL: SPEC-4618 Change-Id: I16b7c8b703b2aa3c875b7ffd78b24021eafd3a7f Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/28186 Tested-by: Jenkins Job builder account ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb b/meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb
new file mode 100644
index 000000000..b182715e0
--- /dev/null
+++ b/meta-agl-core/recipes-graphics/wayland/native-shell-client_git.bb
@@ -0,0 +1,16 @@
+SUMMARY = "Minimal agl-shell Wayland protocol client"
+
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/q/project:src%252Fnative-shell-client"
+SECTION = "x11"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3b90ee643ce04400848a8f0deb492a4a"
+
+DEPENDS = "wayland wayland-protocols wayland-native agl-compositor"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/native-shell-client.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "03249cee92017337b1f2515b98a8f3b37459a256"
+
+PV = "0.0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig