summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>2019-06-07 12:28:41 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-07 19:38:32 +0000
commit9e3e2903101b30e923a3d0bae86f8c36028fdc6b (patch)
tree675f6e7340fdb228ac7cd01728bdd0715a558039
parentcee71afc12c0b05f79ab1b934607682d1ed2762c (diff)
Fix : do_patch waring weston 6.0.0
Backport weston patch to Fix do_patch warning. http://git.yoctoproject.org/cgit/cgit.cgi/poky/tree/meta/recipes-graphics/wayland/weston/0001-make-error-portable.patch -- WARNING: weston-6.0.0-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch 0001-make-error-portable.patch patching file configure.ac Hunk #1 succeeded at 126 with fuzz 2 (offset 17 lines). patching file libweston/weston-error.h patching file libweston/weston-launch.c Now at patch 0001-make-error-portable.patch Bug-AGL: SPEC-2499 Change-Id: If80c4e71be1f58362c78fec9ca6c2ca29d224c39 Signed-off-by: Harunobu Kurokawa <harunobu.kurokawa.dn@renesas.com>
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston/0001-make-error-portable.patch10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston/0001-make-error-portable.patch b/meta-agl-bsp/recipes-graphics/wayland/weston/0001-make-error-portable.patch
index 09ec1559e..0eb3d95a6 100644
--- a/meta-agl-bsp/recipes-graphics/wayland/weston/0001-make-error-portable.patch
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston/0001-make-error-portable.patch
@@ -1,4 +1,4 @@
-From ad1d2161c811cff25d1684c33611f300adb753bc Mon Sep 17 00:00:00 2001
+From c4677e155736062e75687f1a655732c8902e912b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 29 May 2015 20:56:00 -0700
Subject: [PATCH] make error() portable
@@ -18,12 +18,12 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
create mode 100644 libweston/weston-error.h
diff --git a/configure.ac b/configure.ac
-index 7aebbdb..dc9c802 100644
+index c05ad01..6da6e04 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -109,6 +109,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+@@ -126,6 +126,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
+ [AC_MSG_ERROR("CLOCK_MONOTONIC is needed to compile weston")],
[[#include <time.h>]])
- AC_CHECK_HEADERS([execinfo.h])
+AC_CHECK_HEADERS([error.h])
+
@@ -57,7 +57,7 @@ index 0000000..2089d02
+#endif
+
diff --git a/libweston/weston-launch.c b/libweston/weston-launch.c
-index 1adcf21..166bf3b 100644
+index bf73e0d..9064439 100644
--- a/libweston/weston-launch.c
+++ b/libweston/weston-launch.c
@@ -33,7 +33,6 @@