summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>2018-07-20 09:56:22 +0000
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2018-07-24 14:46:46 +0000
commita7526c82254be6708737e01ad27eaa06a65526cf (patch)
tree07abbff5200d9022205ecda935567f83a22fb756
parent398103471451c44e8ccce9fd102e287b6e9b58a2 (diff)
Enable weston to use systemd notify
Enable weston to use systemd notify to reduce causes of race condition between window manager and homescreen. Bug-AGL: SPEC-1471 Change-Id: I6431b5d52f38b982f6691b2961938664cc4f0544 Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/core.cfg1
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston-init/weston.service.add1
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/weston_%.bbappend2
3 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/core.cfg b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/core.cfg
index a0ec1e181..8d809a6a0 100644
--- a/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/core.cfg
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston-ini-conf/core.cfg
@@ -2,3 +2,4 @@
shell=ivi-shell.so
backend=drm-backend.so
require-input=false
+modules=systemd-notify.so
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init/weston.service.add b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init/weston.service.add
index 3596e9c39..b51d2223a 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init/weston.service.add
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston-init/weston.service.add
@@ -1,3 +1,4 @@
+Type=notify
Environment="XDG_RUNTIME_DIR=@XDG_RUNTIME_DIR@"
TTYPath=/dev/tty@WESTONTTY@
StandardInput=tty
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_%.bbappend
new file mode 100644
index 000000000..51e640e06
--- /dev/null
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/weston_%.bbappend
@@ -0,0 +1,2 @@
+PACKAGECONFIG[notify] = "--enable-systemd-notify,--disable-systemd-notify,systemd"
+PACKAGECONFIG_append = " notify"