summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-10-21 17:12:36 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-10-24 09:40:54 +0000
commite3a9459b2f7e5f7a0d7b0be3629bd402d09f7f16 (patch)
tree0a1b7560bac6d106c429cb816fc0a94b9dc6dd1e
parent792f161d649c2457560ea7d4040dc8562451424c (diff)
Make weston variables machine-specific
These variables need to be conditional to qemu* (intel-corei7??) and should not pollute other targets. Use OVERRIDES here to avoid cut-n-paste. Change-Id: I6eec3de2da0143c0a3ee40beaf73ba77acfe0a3d Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
-rw-r--r--meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend11
1 files changed, 8 insertions, 3 deletions
diff --git a/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend b/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
index 74f9e59e4..b117ada46 100644
--- a/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl-bsp/recipes-graphics/wayland/weston_%.bbappend
@@ -4,16 +4,21 @@ RDEPENDS_${PN}_append_qemux86 = " mesa-megadriver"
RDEPENDS_${PN}_append_qemux86-64 = " mesa-megadriver"
RDEPENDS_${PN}_append_intel-corei7-64 = " mesa-megadriver"
-SRC_URI_append = "\
+# OVERRIDES save us some c'n'p below ...
+OVERRIDES_prepend_qemux86 = "customwestonini:"
+OVERRIDES_prepend_qemux86-64 = "customwestonini:"
+# intel-corei7-64 ??
+
+SRC_URI_append_customwestonini = "\
file://weston-qemu-drm.ini \
"
-do_install_append() {
+do_install_append_customwestonini() {
WESTON_CONFIG_DIR=${sysconfdir}/xdg/weston
install -d ${D}${WESTON_CONFIG_DIR}
install -m 0644 ${WORKDIR}/weston-qemu-drm.ini ${D}${WESTON_CONFIG_DIR}/weston.ini
}
-FILES_${PN} += " \
+FILES_${PN}_append_customwestonini = " \
${sysconfdir}/xdg/weston/weston.ini \
"