summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Bachmann <mbc@iot.bzh>2016-01-28 02:35:16 +0000
committerManuel Bachmann <mbc@iot.bzh>2016-02-02 15:17:17 +0000
commitf59c808ae7f7e02dced00d56ef2cbb0acc8a4eb1 (patch)
treef9fc893aee2e1503a8b033e6307385e5282cad27
parente14106703bd02e161bc5518c73be8a07659891cd (diff)
Provide automatic DHCP configuration for Ethernet adapters
systemd now provides the logic necessary to obtain IP connectivity with its networkd/resolved daemons. Let us enable this feature for wired adapters : that is, those prefixed with "eth*" (Renesas R-Car) or "en*" (QEMU). Change-Id: I8e71b8d1f22364ffa8ee0c33769a8dba9e21f71a Signed-off-by: Manuel Bachmann <mbc@iot.bzh>
-rw-r--r--meta-agl/recipes-core/systemd/systemd/wired.network5
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend14
2 files changed, 14 insertions, 5 deletions
diff --git a/meta-agl/recipes-core/systemd/systemd/wired.network b/meta-agl/recipes-core/systemd/systemd/wired.network
new file mode 100644
index 000000000..3559b0155
--- /dev/null
+++ b/meta-agl/recipes-core/systemd/systemd/wired.network
@@ -0,0 +1,5 @@
+[Match]
+Name=eth* en*
+
+[Network]
+DHCP=yes
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index 4e0d5d474..96ca6c69d 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -1,13 +1,17 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-SRC_URI += " file://e2fsck.conf "
+SRC_URI += "file://e2fsck.conf \
+ file://wired.network \
+ "
-# enable networkd support
-PACKAGECONFIG_append_pn-systemd = " networkd"
+# enable networkd/resolved support
+PACKAGECONFIG_append_pn-systemd = " networkd resolved"
do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+ install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}${sysconfdir}/e2fsck.conf
+ # Install DHCP configuration for Ethernet adapters
+ install -m 644 ${WORKDIR}/wired.network ${D}${sysconfdir}/systemd/network
}
-FILES_${PN} += " /etc/e2fsck.conf "
+FILES_${PN} += "${sysconfdir}/e2fsck.conf "