summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf/include
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2021-02-10 13:58:29 -0500
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2021-02-17 18:24:55 +0000
commitf54138fb4bdb79154ad3dc450c30fc9be765d6a5 (patch)
treec8f877eba47fa90a830e97f93a286eb10cf71395 /meta-agl-bsp/conf/include
parent1744b527b6ea0eb105f20cf7b722a7e02406126f (diff)
Update to YP dunfell 3.1.5
Changes include: - Backport gstreamer 1.16.2 vs 1.16.3 workaround for rcar3 (originally for SPEC-3706 in master, now updated per SPEC-3803). - Add 1.16.% wildcard version of meta-rcar-gen3-adas Kingfisher support layer gstreamer1.0-plugins-bad bbappend. The issue is the same as with the main meta-rcar-gen3 BSP layer bbappends mentioned above, but this particular bbappend has been disabled in the newer BSP in master/koi, so they did not need a fix. - Add override of PREFERRED_VERSION_libdrm for rcar3 to quiet warnings about 2.4.100 not being available, which are caused by dunfell 3.1.5 bringing an update to 2.4.101. - Pin Raspberry Pi kernel version to 4.19. meta-raspberrypi upstream has switched their default kernel to 5.4 on their dunfell branch, but that significant of a change is not desirable in a AGL point release. - Remove now upstreamed systemd patch. Bug-AGL: SPEC-3793, SPEC-3803 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: Ia678b8f56f35026a62a9f6ab40f9727b10756ad6 Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/26042 Tested-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/conf/include')
-rw-r--r--meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc3
-rw-r--r--meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi3.inc3
-rw-r--r--meta-agl-bsp/conf/include/agl_raspberrypi4.inc3
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar-nogfx.inc5
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc3
6 files changed, 18 insertions, 1 deletions
diff --git a/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc b/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
index 25755d247..70bc68b2e 100644
--- a/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_h3ulcb-nogfx.inc
@@ -8,3 +8,6 @@ DTB_SUFFIX = "r8a7795-h3ulcb"
BBMASK += "gles-user-module|kernel-module-gles|wayland-kms|libgbm"
# Mask MMP recipes
BBMASK += "kernel-module-uvcs-drv|omx-user-module"
+
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
diff --git a/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc b/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
index 5092c4bcb..28360fcc9 100644
--- a/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_m3ulcb-nogfx.inc
@@ -12,3 +12,5 @@ BBMASK += "kernel-module-uvcs-drv|omx-user-module"
DISTRO_FEATURES_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen', '', d)}"
IMAGE_INSTALL_append = "${@bb.utils.contains('AGL_XEN_WANTED', '1', ' xen-base xen-mkimage', '', d)}"
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi3.inc b/meta-agl-bsp/conf/include/agl_raspberrypi3.inc
index a4989b79a..c0538dd2b 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi3.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi3.inc
@@ -4,6 +4,9 @@ GPU_MEM = "256"
# Add CMA to the kernel arguments for SOTA
OSTREE_KERNEL_ARGS_sota_append = " cma=256M"
+# Use 4.19 kernel for jellyfish
+PREFERRED_VERSION_linux-raspberrypi = "4.19.%"
+
#MULTI_PROVIDER_WHITELIST += "virtual/libgl virtual/egl virtual/libgles1 virtual/libgles2"
# use u-boot always
diff --git a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
index ae302aae1..15ed8c809 100644
--- a/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
+++ b/meta-agl-bsp/conf/include/agl_raspberrypi4.inc
@@ -4,6 +4,9 @@ GPU_MEM = "256"
# Add CMA to the kernel arguments for SOTA
OSTREE_KERNEL_ARGS_sota_append = " cma=256M"
+# Use 4.19 kernel for jellyfish
+PREFERRED_VERSION_linux-raspberrypi = "4.19.%"
+
# use u-boot always
RPI_USE_U_BOOT = "1"
diff --git a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
index 3ffded7c5..3c45fdfdf 100644
--- a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
@@ -10,4 +10,7 @@ RENESAS_DATADIR = "/usr"
IMAGE_INSTALL_append_rcar-gen3 = " \
kernel-devicetree \
-" \ No newline at end of file
+"
+
+# Quiet warnings about unavailable 2.4.100 version due to upstream update
+PREFERRED_VERSION_libdrm_rcar-gen3 = "2.4.101"
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index cfdff9dbf..c14d5d151 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -40,6 +40,9 @@ DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
# testing shows no issues on H3ULCB when not having them.
BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
+# Workaround for SPEC-3706 - versioned bbappends and upstream moved on to 1.16.3
+BBMASK += "meta-renesas/meta-rcar-gen3/recipes-multimedia/gstreamer/gstreamer1.0-.*1.16.2\.bbappend"
+
IMAGE_INSTALL_append_rcar-gen3 = " \
kernel-module-pvrsrvkm \
kernel-module-vsp2 \