summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf/layer.conf
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-11-09 12:36:34 +0100
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-11-09 12:36:34 +0100
commit1b67a50dbffe916280917461a3bdef51c0d628d1 (patch)
tree2895497316a5caaf64af3f386957f293e54589f0 /meta-agl-bsp/conf/layer.conf
parent6247b67fe5b879e6ecae670ad6135029b5078198 (diff)
Allow .bb files in meta-agl-bsp/meta-layername
This change allows hosting full recipes in the bsp adaptation layers if needed. Required by meta-ti until recipes are moved to meta-ti proper. Change-Id: I91a050405f2be314c0eb988ba932dae88d4e624d Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/conf/layer.conf')
-rw-r--r--meta-agl-bsp/conf/layer.conf4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
index dff7f8dcd..031c4f2be 100644
--- a/meta-agl-bsp/conf/layer.conf
+++ b/meta-agl-bsp/conf/layer.conf
@@ -8,9 +8,13 @@ BBPATH =. "${LAYERDIR}:"
# We use either the BBFILE_COLLECTIONS name of the layer directly (meta-ti)
BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
# or we prepend it with meta- (e.g. rpi, fsl*)
BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bbappend' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bb' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
# Add shared recipes among BSPs
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"