summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf/layer.conf
diff options
context:
space:
mode:
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>2016-09-27 15:26:46 +0200
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2016-09-27 19:26:41 +0000
commit620eef2f58569a1be20e73bfd8a772b291535faa (patch)
tree032415a3fa0eb9e6664f78c5cf864239b0dd90ca /meta-agl-bsp/conf/layer.conf
parent50a41b2535567051b5d33385ed5471e7cdef774e (diff)
Extend glob on meta-agl-bsp to support more boards.
rpi and fsl* use a BBFILE_COLLECTIONS value w/o meta. Extend the statement to include these cases. Change-Id: I2d01bd30b40a01df298b1842944596f588f77ae9 Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/conf/layer.conf')
-rw-r--r--meta-agl-bsp/conf/layer.conf5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/layer.conf b/meta-agl-bsp/conf/layer.conf
index fdde8350e..2b4b874e9 100644
--- a/meta-agl-bsp/conf/layer.conf
+++ b/meta-agl-bsp/conf/layer.conf
@@ -4,8 +4,13 @@ BBPATH =. "${LAYERDIR}:"
# Let us add layer-specific bbappends which are only applied when that
# layer is included in our configuration -
# e.g. only add layers if a bsp is present.
+# This is based on the BBFILE_COLLECTIONS name of the layer.
+# We use either the BBFILE_COLLECTIONS name of the layer directly (meta-ti)
BBFILES += "${@' '.join('${LAYERDIR}/%s/recipes*/*/*.bbappend' % layer \
for layer in BBFILE_COLLECTIONS.split())}"
+# or we prepend it with meta- (e.g. rpi, fsl*)
+BBFILES += "${@' '.join('${LAYERDIR}/meta-%s/recipes*/*/*.bbappend' % layer \
+ for layer in BBFILE_COLLECTIONS.split())}"
# Add shared recipes among BSPs
BBFILES += "${LAYERDIR}/recipes-*/*/*.bb ${LAYERDIR}/recipes-*/*/*.bbappend"