summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf
diff options
context:
space:
mode:
authorTakashi Matsuzawa <tmatsuzawa@xevo.com>2017-06-28 15:55:13 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-06-30 19:31:59 +0000
commit1c46fcd4f482be6c114a815d9501adf4b7588d2c (patch)
treea6beddf14432b654eeefa55af3b7f8787ec990be /meta-agl-bsp/conf
parentcff9db0bcb4226e4c85d48f1208e0042da018693 (diff)
Fix i.MX6
Bug-AGL: SPEC-704 This is part of the fixe to make i.MX6 buildable again. Following fixes are included in this change: - adding build target imx6qsabreauto - fixing qt5.8 build error - refine bblayers.conf layer order (for dynamic-layers) - meta-fsl-arm -> meta-freescale layer name change - weston.ini lines (use fbdev-backend.so) - /dev/galcore permission (by /etc/udev/rules.d/zz-dri.rules) - kernel configuraion to include smack, etc. Follwings are stil not addressed yet: - bblayer.conf layer order still have issue re. dynamic-layers - built and booted on imx6qsabreauto only yet. following existing community boards may need update (i have imx6qsabrelite, but no notrogen6x) Note, this fix is prepared independently of nxp or fsl-community, who should follow-up if there are mistakes to be fixed, or updates that they find needed. Update: Refined on review comment regarding tune settings and kernel configurations. The board successfully boots and shows AGL homescreen. But I found I still have problem with USB. lsusb says 'unable to initialize libusb: -99' error which I am still faling to find the cause. Update2: usb issue may be related to dtb configuration in linux-fslc-imx better to be tracked separately Change-Id: If5fa4e5f0450385bcb2648d57e63dc1fc14b0574 Signed-off-by: Takashi Matsuzawa <tmatsuzawa@xevo.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9871 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/conf')
-rw-r--r--meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc b/meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc
new file mode 100644
index 000000000..74879dbbf
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_imx6qsabreauto.inc
@@ -0,0 +1,35 @@
+# Caution: Hand-merge needed when original recipes are updated
+#
+# Here we only have selected lines from the following (and
+# their included) files
+#
+# fslc-wayland.conf
+# fsl-image-multimedia-full.bb
+#
+
+# fslc-wayland.conf
+
+#
+# Followings were intentionally removed from the original recipe
+# to make our set simpler
+#
+# gtk+3-demo clutter-1.0-examples
+#
+
+IMAGE_INSTALL_append = " \
+ packagegroup-fsl-tools-gpu \
+ packagegroup-fsl-gstreamer1.0 \
+ packagegroup-imx-tools-audio \
+ weston weston-init weston-examples \
+"
+
+# fsl-image-multimedia-full.bb
+
+IMAGE_INSTALL_append = " \
+ packagegroup-fsl-gstreamer1.0-full \
+"
+
+# fix build error
+
+SECURITY_CFLAGS_pn-devil = "${SECURITY_NO_PIE_CFLAGS}"
+