summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/conf
diff options
context:
space:
mode:
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-07-01 12:11:51 +0200
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>2020-07-02 19:05:17 +0200
commit4b01cf8d7fccca51654158d331762bb8493ce9ed (patch)
treed01ab60be032fef730096c5f2997c87ffc0593dc /meta-agl-bsp/conf
parent9149f29426df94b6b01200598f6bd3fd7b668bdf (diff)
Review recipes and BBMASK
Review the files added and do MASK them out. Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org> Change-Id: I08135b6bf9c7c2bd9806d6607d2ab77f0e16d752
Diffstat (limited to 'meta-agl-bsp/conf')
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar-nogfx.inc2
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar.inc15
-rw-r--r--meta-agl-bsp/conf/include/agl_rcar_masks.inc38
3 files changed, 41 insertions, 14 deletions
diff --git a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
index 9ba92d106..721f6703d 100644
--- a/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar-nogfx.inc
@@ -1,3 +1,5 @@
+require conf/include/agl_rcar_masks.inc
+
DISTRO_FEATURES_append = " sota"
OSTREE_KERNEL = "Image"
diff --git a/meta-agl-bsp/conf/include/agl_rcar.inc b/meta-agl-bsp/conf/include/agl_rcar.inc
index 0e411f1a7..3ba2e2a77 100644
--- a/meta-agl-bsp/conf/include/agl_rcar.inc
+++ b/meta-agl-bsp/conf/include/agl_rcar.inc
@@ -1,4 +1,5 @@
require conf/include/agl_rcar-nogfx.inc
+require conf/include/agl_rcar_masks.inc
# Enable AGL virtualization features
MACHINE_FEATURES_append = " agl-egvirt"
@@ -29,20 +30,6 @@ DISTRO_FEATURES_append = " use_eva_pkg"
#DISTRO_FEATURES_append = " h265dec_lib mpeg2dec_lib"
DISTRO_FEATURES_append = " h264dec_lib h264enc_lib aaclcdec_lib aaclcdec_mdw"
-# Mask out meta-renesas-rcar-gen3's tweaks to weston-init, as they do
-# not seem necessary for anything in AGL, and the addition of
-# dbus.service and multi-user.target dependencies to the weston systemd
-# unit that is done is problematic with respect to potentially blocking
-# weston if any user units like application framework "platform"
-# services fail. They also likely affect boot up speed with respect to
-# getting weston started. There is no clear rationale expressed in the
-# meta-renesas-rcar-gen3 commit history for the extra dependencies, and
-# testing shows no issues on H3ULCB when not having them.
-BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
-
-# mask out meta-renesas-rcar-gen3's tweaks to base-files / and fstab
-BBMASK += "meta-rcar-gen3/recipes-core/base-files/"
-
IMAGE_INSTALL_append_rcar-gen3 = " \
kernel-devicetree \
kernel-module-pvrsrvkm \
diff --git a/meta-agl-bsp/conf/include/agl_rcar_masks.inc b/meta-agl-bsp/conf/include/agl_rcar_masks.inc
new file mode 100644
index 000000000..b31959e6d
--- /dev/null
+++ b/meta-agl-bsp/conf/include/agl_rcar_masks.inc
@@ -0,0 +1,38 @@
+# Mask out meta-renesas-rcar-gen3's tweaks to weston-init, as they do
+# not seem necessary for anything in AGL, and the addition of
+# dbus.service and multi-user.target dependencies to the weston systemd
+# unit that is done is problematic with respect to potentially blocking
+# weston if any user units like application framework "platform"
+# services fail. They also likely affect boot up speed with respect to
+# getting weston started. There is no clear rationale expressed in the
+# meta-renesas-rcar-gen3 commit history for the extra dependencies, and
+# testing shows no issues on H3ULCB when not having them.
+BBMASK += "meta-rcar-gen3/recipes-graphics/wayland/weston-init.bbappend"
+
+# mask out meta-renesas-rcar-gen3's tweaks to base-files / and fstab
+# AGL uses systemd
+BBMASK += "meta-rcar-gen3/recipes-core/base-files/"
+
+# do not modify core-image-minimal
+BBMASK += "meta-rcar-gen3/recipes-core/images/core-image-minimal.bbappend"
+
+# do not modify the nativesdk-packagegroup-sdk-host
+# the comment mentions YP v2.1.2
+# upstream has this included
+# recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bb: ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'nativesdk-wayland', '', d)}
+# and AGL as well in agl-image-graphical-qt5-crosssdk.inc
+BBMASK += "meta-rcar-gen3/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend"
+
+# do not modify the ncurse package
+# the change is from 2018 and should be re-validated with dunfell and/or upstreamed
+BBMASK += "meta-rcar-gen3/recipes-core/ncurses/"
+
+# do not modify the systemd recipe
+# we have our own ACLs setup for /var due to SMACK !
+# meta-agl/meta-app-framework/recipes-core/base-files/base-files_%.bbappend
+# meta-agl/meta-security/recipes-core/base-files/base-files_%.bbappend
+BBMASK += "meta-rcar-gen3/recipes-core/systemd/"
+
+# do not modify core-image-weston in AGL
+# review it before adding
+#BBMASK += "meta-rcar-gen3/recipes-graphics/images/core-image-weston.bbappend" \ No newline at end of file