summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-agl-refhw-gen3
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2024-02-18 16:04:37 -0500
committerScott Murray <scott.murray@konsulko.com>2024-02-21 13:48:34 +0000
commite19016ae9f2829cf858026bc3b8834d5d239676b (patch)
tree2c2b2c541a5b0a2328841f1750fe7f9fd1d61ec8 /meta-agl-bsp/meta-agl-refhw-gen3
parent63e5c14ba2ec13f7707e48203d5f522d9fbc5616 (diff)
meta-agl-bsp: Rework gpsd configuration
To remove the use of a "virtual/" prefixed RPROVIDES as part of futureproofing for YP 5.0 / Scarthgap, rework the machine-specific gpsd configuration scheme to based on the gpsd-machine-conf recipe that is intended for this upstream. Bug-AGL: SPEC-5067 Change-Id: Ie7fda1e936982e7d43bb0af6ee4e90ab4dae9477 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/29688 ci-image-build: Jenkins Job builder account ci-image-boot-test: Jenkins Job builder account Tested-by: Jenkins Job builder account
Diffstat (limited to 'meta-agl-bsp/meta-agl-refhw-gen3')
-rw-r--r--meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend (renamed from meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb)17
1 files changed, 6 insertions, 11 deletions
diff --git a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
index 25bdb73c8..3cd5aa7de 100644
--- a/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-conf-refhw_1.0.bb
+++ b/meta-agl-bsp/meta-agl-refhw-gen3/recipes-navigation/gpsd/gpsd-machine-conf_1.0.bbappend
@@ -1,8 +1,4 @@
-SUMMARY = "AGL Reference Hardware specific gpsd configuration"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
+FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
SRC_URI = "file://gpsd.refhw \
file://refhw-gpsd-helper.sh \
@@ -16,6 +12,7 @@ do_compile[noexec] = "1"
do_install() {
install -D -m 0644 ${WORKDIR}/gpsd.refhw ${D}/${sysconfdir}/default/gpsd.refhw
+
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
install -D -m 0755 ${WORKDIR}/refhw-gpsd-helper.sh ${D}/${sbindir}/refhw-gpsd-helper.sh
install -d ${D}${sysconfdir}/systemd/system/gpsd.service.d
@@ -23,6 +20,10 @@ do_install() {
fi
}
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+CONFFILES:${PN} = "${sysconfdir}/default/gpsd.refhw"
+
ALTERNATIVE:${PN} = "gpsd-defaults"
ALTERNATIVE_LINK_NAME[gpsd-defaults] = "${sysconfdir}/default/gpsd"
ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.refhw"
@@ -30,9 +31,3 @@ ALTERNATIVE_TARGET[gpsd-defaults] = "${sysconfdir}/default/gpsd.refhw"
# default configuration. The script run by the systemd drop-in
# will tweak things on boot to handle h3ulcb vs refhw.
ALTERNATIVE_PRIORITY[gpsd-defaults] = "5"
-
-CONFFILES:${PN} = "${sysconfdir}/default/gpsd.refhw"
-
-# NOTE: Explicitly not defining RPROVIDES of "virtual/gpsd-conf" to
-# avoid conflicting with the default configuration and potentially
-# changing behavior on m3ulcb/h3ulcb.