summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-boundary
diff options
context:
space:
mode:
authorTom Rini <trini@konsulko.com>2017-11-03 15:29:15 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-11-22 10:07:25 +0000
commit9691b89fd8a0014b7d57c9fc35cf75bfe8da1577 (patch)
tree0cbc41ae0a0c0d4a38e5952f4678c0831fbe6cb7 /meta-agl-bsp/meta-boundary
parent5692de99c4e04d51a6c5da86fea1710d55420873 (diff)
Rework Linux Kernel fragment applications
- All kernel recipes must inherit linux-agl.inc - All kernel recipes for a given version (e.g. 4.9) should include linux-VER-agl.inc in order to avoid duplication (such as the SMACK label patch or security fixes) - We enforce having merge_config.sh be invoked at the end, in order to make sure fragments will be applied. - Add a new fragment for Raspberry Pi to ensure the Pi Touchscreen is still enabled. With all of the above, we fix a number of minor issues as well, such as platforms manually enabling NBD/RAMDISK for netboot as the previous logic was not working in all cases. Bug-AGL: SPEC-946 Change-Id: Ic688e899df5861d83712af12d8e1c6c3c9643300 Signed-off-by: Tom Rini <trini@konsulko.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/12063 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: José Bollo <jobol@nonadev.net> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-boundary')
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg4
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg4
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg3
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg5
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend34
5 files changed, 1 insertions, 49 deletions
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg
deleted file mode 100644
index 6f7d49880..000000000
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg
+++ /dev/null
@@ -1,4 +0,0 @@
-CONFIG_CFG80211=m
-CONFIG_MAC80211=m
-CONFIG_ATH_CARDS=m
-CONFIG_ATH9K_HTC=m
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg
deleted file mode 100644
index 9c2a82d99..000000000
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg
+++ /dev/null
@@ -1,4 +0,0 @@
-CONFIG_BT_INTEL=m
-CONFIG_BT_BCM=m
-CONFIG_BT_HCIBTUSB=m
-CONFIG_BT_HCIBTUSB_BCM=y \ No newline at end of file
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
deleted file mode 100644
index 95de5181e..000000000
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
+++ /dev/null
@@ -1,3 +0,0 @@
-CONFIG_USB_HID=y
-# CONFIG_HID_PID is not set
-CONFIG_HID_MULTITOUCH=y
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg
deleted file mode 100644
index df5a871ef..000000000
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg
+++ /dev/null
@@ -1,5 +0,0 @@
-CONFIG_I2C_MUX=y
-CONFIG_MEDIA_USB_SUPPORT=y
-CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
-CONFIG_DVB_USB_V2=m
-CONFIG_DVB_USB_RTL28XXU=m
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
index 5dbd457df..88ac94b15 100644
--- a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
@@ -1,33 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-
-DEPENDS += "kern-tools-native"
-
-# Enable support for AR9271
-SRC_URI_append = " file://ath9k_htc.cfg"
-
-# Enable support for Bluetooth HCI USB devices
-SRC_URI_append = " file://btusb.cfg"
-
-# Enable support for Bluetooth HCI USB devices
-SRC_URI_append = " file://btusb.cfg"
-
-# Enable support for HID multitouch
-SRC_URI_append = " file://hid.cfg"
-
-# Enable support for RTLSDR
-SRC_URI_append = " file://rtl_sdr.cfg"
-
-# returns all the elements from the src uri that are .cfg files
-def find_cfgs(d):
- sources=src_patches(d, True)
- sources_list=[]
- for s in sources:
- if s.endswith('.cfg'):
- sources_list.append(s)
-
- return sources_list
-
-do_configure_prepend () {
- cp -a ${WORKDIR}/defconfig .config
- merge_config.sh -m .config ${@" ".join(find_cfgs(d))}
-} \ No newline at end of file
+require recipes-kernel/linux/linux-agl.inc