summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-boundary
diff options
context:
space:
mode:
authorNathan Illerbrun <nathani@validmanufacturing.com>2017-01-05 13:46:13 -0800
committerNathan Illerbrun <nathani@validmanufacturing.com>2017-01-09 11:26:57 -0800
commitf5794165ee538ce1afc60b944b2836d7e763c9f4 (patch)
tree492d9a960dacbf767cf8fcb668fd0d60fa398852 /meta-agl-bsp/meta-boundary
parentc2d8e86606ae5d39dcf79f08a2d5222df7df6a66 (diff)
Append kernel recipe to support config fragments and add common kernel config fragments
Add machine template for nitrogen6x Change-Id: I63df939008a36d125f80d74d461453c63386e24e Signed-off-by: Nathan Illerbrun <nathani@validmanufacturing.com>
Diffstat (limited to 'meta-agl-bsp/meta-boundary')
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg4
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg4
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg1
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg5
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg6
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg8
-rw-r--r--meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend35
7 files changed, 63 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg
new file mode 100644
index 000000000..6f7d49880
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/ath9k_htc.cfg
@@ -0,0 +1,4 @@
+CONFIG_CFG80211=m
+CONFIG_MAC80211=m
+CONFIG_ATH_CARDS=m
+CONFIG_ATH9K_HTC=m
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg
new file mode 100644
index 000000000..9c2a82d99
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/btusb.cfg
@@ -0,0 +1,4 @@
+CONFIG_BT_INTEL=m
+CONFIG_BT_BCM=m
+CONFIG_BT_HCIBTUSB=m
+CONFIG_BT_HCIBTUSB_BCM=y \ No newline at end of file
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
new file mode 100644
index 000000000..327c753ae
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/hid.cfg
@@ -0,0 +1 @@
+CONFIG_HID_MULTITOUCH=y
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg
new file mode 100644
index 000000000..df5a871ef
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/rtl_sdr.cfg
@@ -0,0 +1,5 @@
+CONFIG_I2C_MUX=y
+CONFIG_MEDIA_USB_SUPPORT=y
+CONFIG_MEDIA_DIGITAL_TV_SUPPORT=y
+CONFIG_DVB_USB_V2=m
+CONFIG_DVB_USB_RTL28XXU=m
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg
new file mode 100644
index 000000000..5914b3fba
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack-default-lsm.cfg
@@ -0,0 +1,6 @@
+CONFIG_DEFAULT_SECURITY="smack"
+CONFIG_DEFAULT_SECURITY_SMACK=y
+# CONFIG_DEFAULT_SECURITY_SELINUX is not set
+# CONFIG_DEFAULT_SECURITY_APPARMOR is not set
+# CONFIG_DEFAULT_SECURITY_YAMA is not set
+# CONFIG_DEFAULT_SECURITY_DAC is not set \ No newline at end of file
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg
new file mode 100644
index 000000000..62f465a45
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/files/smack.cfg
@@ -0,0 +1,8 @@
+CONFIG_IP_NF_SECURITY=m
+CONFIG_IP6_NF_SECURITY=m
+CONFIG_EXT2_FS_SECURITY=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_EXT4_FS_SECURITY=y
+CONFIG_SECURITY=y
+CONFIG_SECURITY_SMACK=y
+CONFIG_TMPFS_XATTR=y
diff --git a/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
new file mode 100644
index 000000000..e2996f95c
--- /dev/null
+++ b/meta-agl-bsp/meta-boundary/recipes-kernel/linux/linux-boundary_4.1.15.bbappend
@@ -0,0 +1,35 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+# Enable support for AR9271
+SRC_URI_append = " file://ath9k_htc.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+
+# Enable support for Bluetooth HCI USB devices
+SRC_URI_append = " file://btusb.cfg"
+
+# Enable support for HID multitouch
+SRC_URI_append = " file://hid.cfg"
+
+# Enable support for RTLSDR
+SRC_URI_append = " file://rtl_sdr.cfg"
+
+# Set security default to SMACK
+SRC_URI_append = " file://smack.cfg"
+SRC_URI_append = " file://smack-default-lsm.cfg"
+
+# returns all the elements from the src uri that are .cfg files
+def find_cfgs(d):
+ sources=src_patches(d, True)
+ sources_list=[]
+ for s in sources:
+ if s.endswith('.cfg'):
+ sources_list.append(s)
+
+ return sources_list
+
+do_configure_prepend () {
+ cp -a ${WORKDIR}/defconfig .config
+ merge_config.sh -m .config ${@" ".join(find_cfgs(d))}
+} \ No newline at end of file