summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-core
diff options
context:
space:
mode:
authorCorentin Labbe <clabbe@baylibre.com>2019-05-23 08:59:27 +0000
committerCorentin Labbe <clabbe@baylibre.com>2019-05-28 06:54:04 +0000
commitae753811d24be1377c4f5c29c3131384f6db10f7 (patch)
treeaaa8bdfa1a13e72efafeb6042f2a6c5f1ce8b09c /meta-agl-bsp/meta-core
parent677c2cc7672143744170da5130bf4c22044a0fae (diff)
SPEC-2376: Add virtio configs for QEMU arm/arm64 kernels
QEMU arm/arm64 need some VIRTIO configs for having storage for rootfs. Bug-AGL: SPEC-2376 Change-Id: Ia4b53092418b9f5e4040b8dafc58262a98bcac46 Signed-off-by: Corentin Labbe <clabbe@baylibre.com>
Diffstat (limited to 'meta-agl-bsp/meta-core')
-rw-r--r--meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg4
-rw-r--r--meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend1
2 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg
new file mode 100644
index 000000000..9bdc2c64e
--- /dev/null
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto/virtio.cfg
@@ -0,0 +1,4 @@
+# qemu need a virtio storage for rootfs
+CONFIG_BLK_MQ_VIRTIO=y
+CONFIG_VIRTIO=y
+CONFIG_VIRTIO_BLK=y
diff --git a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
index bfb0d323d..d8a583926 100644
--- a/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
+++ b/meta-agl-bsp/meta-core/recipes-kernel/linux/linux-yocto_%.bbappend
@@ -2,6 +2,7 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/linux-yocto:"
# Extra configuration options for the QEMU kernel
SRC_URI += "file://hciattach.cfg \
+ file://virtio.cfg \
"
# Enable some things on qemuarm64 so MOST drivers will build and load.