summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-graphics
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-12-08 09:12:57 -0500
committerScott Murray <scott.murray@konsulko.com>2020-12-11 21:52:08 +0000
commitae3ab75cd4c84b65b7344470ba9ae1d45df15104 (patch)
tree5b63b7b53a85d1eb6813124940cc9b18e9c140c0 /meta-agl-bsp/meta-freescale-layer/recipes-graphics
parentadea5390e04cebf16fec8237870945179508efc4 (diff)
meta-agl-bsp: Update i.MX8MQ EVK support for latest dunfell
The layer updates to go to the latest 3.1.4 Yocto dunfell release broke the imx8mqevk and imx8mqevk-viv builds, though for different reasons. imx8mqevk fixes: - Remove the now upstreamed etnaviv kernel patches that had been backported by Walter. - Turn off btrfs support in the linux-fslc-imx kernel configuration. This is required due to meta-freescale having a 5.4 kernel new enough to need a lttng-modules fix for btrfs that has not yet been backported from the Yocto master branch to dunfell. - Update the PREFERRED_VERSION over-rides in agl_imx8mqevk.inc to match the new versions of libdrm and gstreamer in poky. imx8mqevk-viv fixes: - Add weston_8.0.0.imx.bbappend to work around the broken addition of a PACKAGECONFIG_remove of "x11 wayland" in the recipe in meta-freescale. Upstream will be engaged to drive getting the change reverted. Bug-AGL: SPEC-3725 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I259f2d048a9de653a0060afcef17c4410093783a Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl/+/25772 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-boot-test: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-graphics')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend
new file mode 100644
index 000000000..7928342e1
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-graphics/wayland/weston_8.0.0.imx.bbappend
@@ -0,0 +1,10 @@
+# Work around PACKAGECONFIG_remove of "x11 wayland" added to the recipe
+# in meta-freescale commit 5a5c5dd. This can be removed once the issue
+# has been resolved by a revert of that breakage upstream.
+# What is done below is effectively a disabling of the "wayland"
+# PACKAGECONFIG option and then open coding what its effects would
+# normally be, since the _remove prevents specifying it in the usual way.
+PACKAGECONFIG[wayland] = ""
+DEPENDS_append = " virtual/egl virtual/libgles2"
+PACKAGECONFIG_CONFARGS_append = " -Dbackend-wayland=true"
+