summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-12 15:15:17 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-20 10:53:32 +0000
commit45edb36ac263a9c09ab9d3964cc58b648ed82af0 (patch)
treef1852d5dc9ddbf30bc41b24fa7c9a5ba99a62cb7 /meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
parentfa766117b90a216e9903ee12ede779e66b55e546 (diff)
meta-agl-bsp: Changes to get imx6qdlsabreauto working with etnaviv
Update imx6qdlsabreauto configuration to use open source etnaviv GPU driver instead of Vivante. The previously required weston-ini-conf has been removed as it is not required with etnaviv, and a bbappend has been added for the linux-fslc kernel that this configuration uses so it will pull in the AGL kernel bits. Additionally, the kernel configuration for linux-fslc is tweaked with config fragments to better match the other AGL platforms. Bug-AGL: SPEC-1674, SPEC-2502 Change-Id: Ic40d310b48405ccc7d1435f0fc9f162a129cffe9 Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
new file mode 100644
index 000000000..4fa422136
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
@@ -0,0 +1,20 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+require recipes-kernel/linux/linux-agl.inc
+
+# Make sure these are enabled so that AGL configurations work
+SRC_URI_append = " file://tmpfs.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/tmpfs.cfg"
+SRC_URI_append = " file://namespace.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/namespace.cfg"
+SRC_URI_append = " file://cgroup.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cgroup.cfg"
+
+# Support for CFG80211 subsystem
+SRC_URI_append = " file://cfg80211.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
+
+# Turn off a couple of things enabled by default by Freescale
+# (lock debugging and userspace firmware loader fallback)
+SRC_URI_append = " file://fixups.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fixups.cfg"