summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer/recipes-kernel
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2020-05-07 15:55:04 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2020-05-12 23:34:44 +0000
commit4ee8c933aa9726f0493ead14b4e1c97a0844ec28 (patch)
tree59ce1ebb4080a4b0dc29b8e45023ce5b5ab44cf1 /meta-agl-bsp/meta-freescale-layer/recipes-kernel
parent8b1baf589ebad0862791c32c7a9b953071dec20a (diff)
Add i.MX8MQ EVK support
Add imx8mqevk-viv machine template for i.MX8MQ EVK which uses the default Vivante driver configuration in meta-freescale with the new community linux-fslc-imx kernel. The following additional changes have been made to support this: - A linux-fslc-imx bbappend has been added to pull in the AGL kernel configuration, and a imx8mq-evkb config fragment has been added to enable the required Wifi driver for the updated EVKB board. - Stale qtbase and weston-init bbappends/patches have been removed from meta-agl-bsp/meta-freescale-layer. - The meta-agl-profile-graphical Weston 8.0.0 bbappend has been renamed to 8.0.% so the wildcard will apply it to meta-freescale's weston_8.0.0.imx recipe. Known issues: - The required PipeWire configuration for the onboard audio needs further investigation. Bug-AGL: SPEC-3258 Signed-off-by: Scott Murray <scott.murray@konsulko.com> Change-Id: I4ea5437ef0ea8bedb9dd2157f2822ff25ee56cff
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer/recipes-kernel')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/files/imx8mq-evkb.cfg1
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend24
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/files/imx8mq-evkb.cfg b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/files/imx8mq-evkb.cfg
new file mode 100644
index 000000000..92915921f
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/files/imx8mq-evkb.cfg
@@ -0,0 +1 @@
+CONFIG_BRCMSMAC=m
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
new file mode 100644
index 000000000..33e72bf7d
--- /dev/null
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc-imx_%.bbappend
@@ -0,0 +1,24 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+require recipes-kernel/linux/linux-agl.inc
+
+# Make sure these are enabled so that AGL configurations work
+SRC_URI_append = " file://tmpfs.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/tmpfs.cfg"
+SRC_URI_append = " file://namespace.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/namespace.cfg"
+SRC_URI_append = " file://cgroup.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cgroup.cfg"
+
+# Support for CFG80211 subsystem
+SRC_URI_append = " file://cfg80211.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
+
+# Support for i.MX8MQ EVKB (e.g. Broadcom wifi)
+SRC_URI_append_imx8mqevk = " file://imx8mq-evkb.cfg"
+KERNEL_CONFIG_FRAGMENTS_append_imx8mqevk = " ${WORKDIR}/imx8mq-evkb.cfg"
+
+# Turn off a couple of things enabled by default by Freescale
+# (lock debugging and userspace firmware loader fallback)
+SRC_URI_append = " file://fixups.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fixups.cfg"