summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-freescale-layer
diff options
context:
space:
mode:
authorScott Murray <scott.murray@konsulko.com>2019-06-12 15:34:43 -0400
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2019-06-20 10:54:04 +0000
commit7e6f5bb94352ac0b6cd5c5cdd3035eec6c6bc559 (patch)
tree95ce7540453cb447fdde679d54df91694228d732 /meta-agl-bsp/meta-freescale-layer
parent45edb36ac263a9c09ab9d3964cc58b648ed82af0 (diff)
Add cubox-i and nitrogen6x i.MX6 machines
Add the cubox-i (covering SolidRun Cubox-i, Hummingboard Gate and Edge), and nitrogen6x (covering Nitrogen 6x and SABRE Lite) machine definitions. Note that support for the Broadcom Bluetooth chipset on the SolidRun i.MX6 SOM is currently missing, as it requires firmware that is not available in either the linux-firmware package or from the firmware packages provided by meta-freescale. Bug-AGL: SPEC-2517 Change-Id: If7bdb9f1af9bb67dba5c1ff836a6d3b04160fefd Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Diffstat (limited to 'meta-agl-bsp/meta-freescale-layer')
-rw-r--r--meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
index 4fa422136..640f9cfe5 100644
--- a/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
+++ b/meta-agl-bsp/meta-freescale-layer/recipes-kernel/linux/linux-fslc_%.bbappend
@@ -18,3 +18,8 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/cfg80211.cfg"
# (lock debugging and userspace firmware loader fallback)
SRC_URI_append = " file://fixups.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fixups.cfg"
+
+do_install_append_cubox-i() {
+ # Add symlink to work with default Hummingboard 2 u-boot configuration
+ ln -sf imx6q-hummingboard2.dtb ${D}/boot/imx6q-hummingboard2-emmc.dtb
+}