summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-intel
diff options
context:
space:
mode:
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>2017-09-14 17:43:18 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-09-18 03:46:30 +0000
commitefed2d255dccafb8ae44f7d71b92b937ad5c42d8 (patch)
tree3024648c65f807397836edf874f4e5f623402075 /meta-agl-bsp/meta-intel
parente48cb247218a9274faa78c535c95d0e0dbaa4686 (diff)
Add uvc.cfg for usb video class kernel configure
Add uvc.cfg into meta-agl-bsp/recipes-kernel, Then include this cfg in each board bbappend. See: https://gerrit.automotivelinux.org/gerrit/#/c/10803/ Change-Id: I5faebefef3560a27496103e1ad4a1ca70377a1ba Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/10893 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-intel')
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend3
-rw-r--r--meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend3
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
index 26063479e..68149e5a2 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.4%.bbappend
@@ -18,3 +18,6 @@ SRC_URI_prepend_intel-corei7-64 = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE',
KERNEL_FEATURES_remove_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', 'features/amt/mei/mei.scc', '', d)}"
KERNEL_FEATURES_append_corei7-64-intel-common = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', ' features/mei/mei-spd.scc', '', d)}"
SRC_URI_append = "${@bb.utils.contains('INTEL_MACHINE_SUBTYPE', 'broxton-m', ' file://security-tpm.cfg', '', d)}"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"
diff --git a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend
index 65484da51..d524ebfa4 100644
--- a/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend
+++ b/meta-agl-bsp/meta-intel/recipes-kernel/linux/linux-yocto_4.9%.bbappend
@@ -7,3 +7,6 @@ KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/usb-devices.cfg"
# adding support for other graphic cards to work on more PC HW
SRC_URI_append = " file://extra-graphic-devices.cfg"
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/extra-graphic-devices.cfg"
+
+# Enable support for usb video class for usb camera devices
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/uvc.cfg"