summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb
diff options
context:
space:
mode:
authorYuya Ono <Ono.Yuya@ap.MitsubishiElectric.co.jp>2018-05-28 11:24:51 +0900
committerYuya Ono <Ono.Yuya@ap.MitsubishiElectric.co.jp>2018-05-28 11:24:51 +0900
commitabfcc560ca9635625537a08c8674c1299c8ee4e1 (patch)
tree1eb08cf89b4a0250aba355e970088b0fa744da3e /meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb
parent8be767a00d15e0c6413da31926263897a3958263 (diff)
dragonboard-410c: update 96boards-tools recipe
Update 96boards-tools recipe for dragonboard-410c. This recipe is ported from meta-96boards layer(rocko). https://github.com/96boards/meta-96boards/ Change-Id: I4a56bddabebfde48ee2a25e180d6ed452b5e0e38 Signed-off-by: Yuya Ono <Ono.Yuya@ap.MitsubishiElectric.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb
new file mode 100644
index 000000000..446770f8e
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.12.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Useful bits an pieces to make 96Boards more standard across the board"
+HOMEPAGE = "https://github.com/96boards/96boards-tools"
+SECTION = "devel"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRCREV = "ed0f0dbec02c1869a0c4fa0140b4aa5338c9d010"
+SRC_URI = "git://github.com/96boards/96boards-tools;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit systemd allarch update-rc.d
+
+do_install () {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0755 ${S}/*.rules ${D}${sysconfdir}/udev/rules.d/
+ install -d ${D}${sysconfdir}/init.d
+ install -m 0755 ${S}/resize-disk ${D}${sysconfdir}/init.d/
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${S}/resize-helper.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/resize-helper ${D}${sbindir}
+}
+
+INITSCRIPT_NAME = "resize-disk"
+INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
+
+SYSTEMD_SERVICE_${PN} = "resize-helper.service"
+RDEPENDS_${PN} += "e2fsprogs-resize2fs gptfdisk parted util-linux udev"