summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-03 10:17:59 +0900
committerKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-02-03 10:17:59 +0900
commit8360d714b7373386f4bebeb434dbc6f0a4a49b9d (patch)
tree8dcc906e4f6fbb8710fc11dca20a6c6cab6a10fa /meta-agl-bsp/meta-qcom
parent352bca8be39cf61c6dea758a76178ef577532f08 (diff)
Enable smack in linux-linaro-qcomlt kernel
This changes enables the smack feature in linux-linaro-qcomlt kernel by using configuration fragments. Change-Id: I54183ffcf31f63ea99ba785442e1833299c3f273 Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>
Diffstat (limited to 'meta-agl-bsp/meta-qcom')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack-default-lsm.cfg2
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack.cfg8
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bbappend6
3 files changed, 14 insertions, 2 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack-default-lsm.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack-default-lsm.cfg
new file mode 100644
index 000000000..b5c48454e
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack-default-lsm.cfg
@@ -0,0 +1,2 @@
+CONFIG_DEFAULT_SECURITY="smack"
+CONFIG_DEFAULT_SECURITY_SMACK=y
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack.cfg b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack.cfg
new file mode 100644
index 000000000..62f465a45
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/files/smack.cfg
@@ -0,0 +1,8 @@
+CONFIG_IP_NF_SECURITY=m
+CONFIG_IP6_NF_SECURITY=m
+CONFIG_EXT2_FS_SECURITY=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_EXT4_FS_SECURITY=y
+CONFIG_SECURITY=y
+CONFIG_SECURITY_SMACK=y
+CONFIG_TMPFS_XATTR=y
diff --git a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bbappend b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bbappend
index c6aee5889..2af182032 100644
--- a/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bbappend
+++ b/meta-agl-bsp/meta-qcom/recipes-kernel/linux/linux-linaro-qcomlt%.bbappend
@@ -1,10 +1,12 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
# Extra configuration options
-SRC_URI += "file://fanotify.cfg \
+SRC_URI += "file://smack.cfg \
+ file://smack-default-lsm.cfg \
+ file://fanotify.cfg \
file://uinput.cfg \
file://hid.cfg "
-KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/fanotify.cfg ${WORKDIR}/uinput.cfg ${WORKDIR}/hid.cfg"
+KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/smack.cfg ${WORKDIR}/smack-default-lsm.cfg ${WORKDIR}/fanotify.cfg ${WORKDIR}/uinput.cfg ${WORKDIR}/hid.cfg"
# Enable support for TP-Link TL-W722N USB Wifi adapter
SRC_URI += " file://ath9k_htc.cfg "