summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-qcom
diff options
context:
space:
mode:
authorKotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp>2017-05-15 18:33:59 +0900
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>2017-05-16 04:52:27 +0000
commitf2cbb76e3d640d4318adbf7c5c31c8619968006f (patch)
tree7ba0f26349652bdd588962649b4fa69f123f3dc2 /meta-agl-bsp/meta-qcom
parent6ca247d19f2a0d7cc0cb1beb8d26c99e7fac337b (diff)
dragonboard-410c: install 96boards-tools for resizing partition
Add 96boards-tools recipe for dragonboard-410c. This tool resize the rootfs on the first boot. The adding recipe is ported from meta-96boars layer(branch morty). https://github.com/96boards/meta-96boards/ Change-Id: Ica597e36e530533cf4820a3b0a7ad2145bd3d6fb Signed-off-by: Kotaro Hashimoto <Hashimoto.Kotaro@ds.MitsubishiElectric.co.jp> Reviewed-on: https://gerrit.automotivelinux.org/gerrit/9391 Tested-by: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> ci-image-build: Jenkins Job builder account <agl-jobbuilder@automotivelinux.org> Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Diffstat (limited to 'meta-agl-bsp/meta-qcom')
-rw-r--r--meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb
new file mode 100644
index 000000000..36a983198
--- /dev/null
+++ b/meta-agl-bsp/meta-qcom/recipes-bsp/96boards-tools/96boards-tools_0.7.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Useful bits an pieces to make 96Boards more standard across the board"
+HOMEPAGE = "https://github.com/96boards/96boards-tools"
+SECTION = "devel"
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRCREV = "193f355823d9dc38f370759153ac950a2833b0e2"
+SRC_URI = "git://github.com/96boards/96boards-tools;branch=master;protocol=https"
+
+S = "${WORKDIR}/git"
+
+inherit systemd allarch
+
+do_install () {
+ install -d ${D}${sysconfdir}/udev/rules.d
+ install -m 0755 ${S}/*.rules ${D}${sysconfdir}/udev/rules.d/
+
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${S}/resize-helper.service ${D}${systemd_unitdir}/system
+
+ install -d ${D}${sbindir}
+ install -m 0755 ${S}/resize-helper ${D}${sbindir}
+}
+
+SYSTEMD_SERVICE_${PN} = "resize-helper.service"
+RDEPENDS_${PN} += "e2fsprogs-resize2fs gptfdisk parted util-linux udev"